summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-08-01 01:01:46 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-08-01 01:01:46 +0000
commit203d71538f039d89f5fd432800fc2c9fa006a732 (patch)
tree85351226ac151cbff45a4ec69dde0ee19eccd950
parentVersion bump. Closes bug #21809 (diff)
downloadgentoo-2-203d71538f039d89f5fd432800fc2c9fa006a732.tar.gz
gentoo-2-203d71538f039d89f5fd432800fc2c9fa006a732.tar.bz2
gentoo-2-203d71538f039d89f5fd432800fc2c9fa006a732.zip
Version bump. Closes bug #21809
-rw-r--r--net-irc/epic4/ChangeLog7
-rw-r--r--net-irc/epic4/Manifest4
-rw-r--r--net-irc/epic4/epic4-1.1.12.ebuild78
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.122
4 files changed, 88 insertions, 3 deletions
diff --git a/net-irc/epic4/ChangeLog b/net-irc/epic4/ChangeLog
index 75e1212baf43..7956180081d6 100644
--- a/net-irc/epic4/ChangeLog
+++ b/net-irc/epic4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/epic4
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.15 2003/07/18 18:47:41 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.16 2003/08/01 01:01:39 gregf Exp $
+
+*epic4-1.1.12 (31 Jul 2003)
+
+ 31 Jul 2003; Greg Fitzgerald <gregf@gentoo.org> epic4-1.1.12.ebuild:
+ Version bump. Fixes bug #21809.
18 Jul 2003; Martin Schlemmer <azarah@gentoo.org> epic4-1.0.1-r2.ebuild,
files/epic4-1.0.1-gcc33.patch:
diff --git a/net-irc/epic4/Manifest b/net-irc/epic4/Manifest
index c37013be5a57..f84faf089391 100644
--- a/net-irc/epic4/Manifest
+++ b/net-irc/epic4/Manifest
@@ -1,9 +1,9 @@
MD5 6af2fc262952ad088d7886c4853f0993 epic4-1.0.1-r2.ebuild 1771
MD5 1bf12e87afe4258b9f0e11ca31a11791 epic4-1.1.10.ebuild 2091
MD5 6b5e83ef842d46128b50379f424a2454 epic4-1.1.7-r1.ebuild 1939
-MD5 616e041798d3bcb508fe77f44c0ffba1 epic4-1.1.12.ebuild 2054
+MD5 302c790a55ca46c8640970a4075d98b7 epic4-1.1.12.ebuild 2055
MD5 75544b79d292a2ff9be99c4c50d9bfad epic4-1.0.1-r1.ebuild 1068
-MD5 1fa470ff01f60fb326ee8e108db3d0b2 ChangeLog 3558
+MD5 c3f84101e5f9d952d8a6257a12ca9d56 ChangeLog 3557
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 616e041798d3bcb508fe77f44c0ffba1 epic4-1.1.11.ebuild 2054
MD5 8ba4ab73d80b324a49ecb94ec8f82198 epic4-1.1.7.ebuild 1454
diff --git a/net-irc/epic4/epic4-1.1.12.ebuild b/net-irc/epic4/epic4-1.1.12.ebuild
new file mode 100644
index 000000000000..d403ee2754a3
--- /dev/null
+++ b/net-irc/epic4/epic4-1.1.12.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.12.ebuild,v 1.1 2003/08/01 01:01:39 gregf Exp $
+
+IUSE="ipv6 perl ssl tcltk"
+
+DESCRIPTION="Epic4 IRC Client"
+SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
+HOMEPAGE="http://epicsol.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ~ppc"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ tcltk? ( dev-lang/tcl )"
+
+inherit flag-o-matic
+replace-flags "-O?" "-O"
+
+src_compile() {
+ myconf=""
+
+ use ipv6 \
+ && myconf="${myconf} --with-ipv6" \
+ || myconf="${myconf} --without-ipv6"
+
+ use perl \
+ && myconf="${myconf} --with-perl" \
+ || myconf="${myconf} --without-perl"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use tcltk \
+ && myconf="${myconf} --with-tcl" \
+ || myconf="${myconf} --without-tcl"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die
+
+ rm -f ${D}/usr/bin/epic
+ dosym epic-EPIC4-${PV} /usr/bin/epic
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+ docinto doc
+ cd doc
+ dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
+ dodoc nicknames outputhelp server_groups SILLINESS TS4
+
+ dodir /usr/share/epic
+ tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
+}
+
+pkg_postinst() {
+ einfo "If /usr/share/epic/script/local does not exist, I will now"
+ einfo "create it. If you do not like the look/feel of this file, or"
+ einfo "if you'd prefer to use your own script, simply remove this"
+ einfo "file. If you want to prevent this file from being installed"
+ einfo "in the future, simply create an empty file with this name."
+
+ if [ ! -e /usr/share/epic/script/local ]; then
+ cp ${FILESDIR}/local /usr/share/epic/script/
+ fi
+}
diff --git a/net-irc/epic4/files/digest-epic4-1.1.12 b/net-irc/epic4/files/digest-epic4-1.1.12
new file mode 100644
index 000000000000..c3b5400b2cb2
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-1.1.12
@@ -0,0 +1,2 @@
+MD5 dd56e54e3530c281e25929924911fd46 epic4-1.1.12.tar.bz2 578986
+MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157