summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-28 02:36:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-28 02:36:56 +0000
commit0fa3faa0401fa633a817798a3476d53f6e811bb3 (patch)
treedf462819a2527768d56493ea57668f102977a4a8
parentFix manifest (diff)
downloadgentoo-2-0fa3faa0401fa633a817798a3476d53f6e811bb3.tar.gz
gentoo-2-0fa3faa0401fa633a817798a3476d53f6e811bb3.tar.bz2
gentoo-2-0fa3faa0401fa633a817798a3476d53f6e811bb3.zip
Version bump.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-4.6_rc2.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index ccbb93711e78..f74f5c70dd92 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.128 2010/11/27 18:01:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.129 2010/11/28 02:36:56 arfrever Exp $
+
+*icu-4.6_rc2 (28 Nov 2010)
+
+ 28 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icu-4.6_rc2.ebuild:
+ Version bump.
27 Nov 2010; Raúl Porcel <armin76@gentoo.org> icu-4.4.2.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #343759
diff --git a/dev-libs/icu/icu-4.6_rc2.ebuild b/dev-libs/icu/icu-4.6_rc2.ebuild
new file mode 100644
index 000000000000..739f62de38b3
--- /dev/null
+++ b/dev-libs/icu/icu-4.6_rc2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.6_rc2.ebuild,v 1.1 2010/11/28 02:36:56 arfrever Exp $
+
+EAPI="3"
+
+inherit versionator
+
+#MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
+#MICRO_VERSION="$(get_version_component_range 3)"
+MAJOR_MINOR_VERSION="$(get_version_component_range 1-3)"
+MICRO_VERSION="$(get_version_component_range 4)"
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+#BASE_URI="http://download.icu-project.org/files/icu4c/${PV}"
+#DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${MAJOR_MINOR_VERSION}"
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
+DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${MAJOR_MINOR_VERSION//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${DOCS_BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+#QA_DT_NEEDED="/usr/lib.*/libicudata.so.${MAJOR_MINOR_VERSION/./}.${MICRO_VERSION:-0}"
+QA_DT_NEEDED="/usr/lib.*/libicudata.so.46.${MICRO_VERSION:-0}"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode flags into icu-config.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ local variable
+ for variable in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
+ done
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"* || die "doins failed"
+ fi
+}