summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-26 10:10:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-26 10:10:45 +0000
commit0a16bb740b37db8f042bd5851288532c0676d9a2 (patch)
tree90fd2649892f800bfb388a1cf7d28f4dc09ff2c1
parentAdd sed for sparc crosscompiler removal (diff)
downloadgentoo-2-0a16bb740b37db8f042bd5851288532c0676d9a2.tar.gz
gentoo-2-0a16bb740b37db8f042bd5851288532c0676d9a2.tar.bz2
gentoo-2-0a16bb740b37db8f042bd5851288532c0676d9a2.zip
Fix build with -parrot #530728
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-lang/rakudo/ChangeLog5
-rw-r--r--dev-lang/rakudo/rakudo-2014.11-r1.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-lang/rakudo/ChangeLog b/dev-lang/rakudo/ChangeLog
index 78f4871277ea..65731adfdc78 100644
--- a/dev-lang/rakudo/ChangeLog
+++ b/dev-lang/rakudo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/rakudo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/ChangeLog,v 1.65 2014/11/25 04:47:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/ChangeLog,v 1.66 2014/11/26 10:10:45 patrick Exp $
+
+ 26 Nov 2014; Patrick Lauer <patrick@gentoo.org> rakudo-2014.11-r1.ebuild:
+ Fix build with -parrot #530728
*rakudo-2014.11-r1 (25 Nov 2014)
diff --git a/dev-lang/rakudo/rakudo-2014.11-r1.ebuild b/dev-lang/rakudo/rakudo-2014.11-r1.ebuild
index c2581d8f2397..1649478d32a4 100644
--- a/dev-lang/rakudo/rakudo-2014.11-r1.ebuild
+++ b/dev-lang/rakudo/rakudo-2014.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.11-r1.ebuild,v 1.1 2014/11/25 04:47:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.11-r1.ebuild,v 1.2 2014/11/26 10:10:45 patrick Exp $
EAPI=5
@@ -33,7 +33,9 @@ src_configure() {
perl Configure.pl --backends=${myconf} --prefix=/usr || die
# why doesn't ops2c get detected?! :(
- use parrot && sed -i -e 's~OPS2C = $(PARROT_BIN_DIR)/$(EXE)~OPS2C = $(PARROT_BIN_DIR)/ops2c~' Makefile || die
+ if use parrot; then
+ sed -i -e 's~OPS2C = $(PARROT_BIN_DIR)/$(EXE)~OPS2C = $(PARROT_BIN_DIR)/ops2c~' Makefile || die
+ fi
}
src_test() {