summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2011-06-14 17:47:47 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2011-06-14 17:47:47 -0500
commit68b1e808129bbd1b64430361c9fae7401b685e64 (patch)
treeea2eaeaed68fb106dd50a8d84fdba8f4c81264fb /net-print
parentVersion bump (diff)
downloadsattvik-68b1e808129bbd1b64430361c9fae7401b685e64.tar.gz
sattvik-68b1e808129bbd1b64430361c9fae7401b685e64.tar.bz2
sattvik-68b1e808129bbd1b64430361c9fae7401b685e64.zip
cupsd updates
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/Manifest3
-rw-r--r--net-print/cups/cups-1.4.6-r1.ebuild43
-rw-r--r--net-print/cups/cups-1.4.6-r21.ebuild296
3 files changed, 325 insertions, 17 deletions
diff --git a/net-print/cups/Manifest b/net-print/cups/Manifest
index 9a7de2d..12fd2ab 100644
--- a/net-print/cups/Manifest
+++ b/net-print/cups/Manifest
@@ -22,6 +22,7 @@ AUX pdftops-1.20.gentoo 10412 RMD160 16e229662c47e03af1d1f4cb5764a76d17a66642 SH
DIST cups-1.3.11-source.tar.bz2 3799393 RMD160 a0646f2ba29fbd39d211ea5c3fdbd24a00f66a78 SHA1 df5cfb64fb608fc128acadde670dc30af49bdb18 SHA256 5e310fd324a15fae1e1c9721879f5c948d788e04735a5263a40c6146fff607b8
DIST cups-1.4.6-source.tar.bz2 4517061 RMD160 94c9921e03f5ec52d9c16947435622365f53aef6 SHA1 42fb1ca00ee7291561564d3072716eb2045f05d1 SHA256 f08711702a77b52c7150f96fe1f45482f6151cb95ef601268c528607fe6ad514
EBUILD cups-1.3.11-r4.ebuild 8230 RMD160 06cae988bc72fd05846e74c736798294c948ea1d SHA1 4a88b7dd7c62690e4e3ebdd3c8da1087ba5f94d9 SHA256 b7643b9e72c90fa66078ab8d4af8af463d1bfdf837e465e9fc078276e418493d
-EBUILD cups-1.4.6-r1.ebuild 8099 RMD160 2a044965b270e4b2a48413a7381c9f02f6c63b23 SHA1 e313bd3a8b091f197c7c10bda59bc30fd0d882ce SHA256 14d6eacf78e0f82de19616abfda1946a8377daca585c70eee958bfa90cb705ea
+EBUILD cups-1.4.6-r1.ebuild 8579 RMD160 44ceddc76420f0ddae9f63529986d15220b4ac55 SHA1 5dfcdbcd392501e172be9114a502a69d9e98afde SHA256 38a65433fc9d00c329abcf6f246aeaf178c1a55cfcce194c9ce27f15b4d72118
+EBUILD cups-1.4.6-r21.ebuild 8509 RMD160 6178c8831132937a82ab0c5452c6f46e3b3d1879 SHA1 3f51dd19726a31c71c3fda6def94c112974434b9 SHA256 a10216bb3af633739ac6aefa06d4e89aa88690f774768bdf66a03b7569a09b16
MISC ChangeLog 2355 RMD160 c482e4cc7b35d71a58c24f2c6ff1321f527e6a1d SHA1 fdbf7dee70844746fdcad76d50bcb4cb26f716fe SHA256 6767cca086602520a58b196007eb4c5429ef96db7559fd901fc491621c2fd976
MISC metadata.xml 161 RMD160 1e5b1e42553c8869b93c4a5448e9a2a2ed9fe525 SHA1 209c6a46e4cdd891980115e42ba419e3799f8088 SHA256 7c85e6739a71f5bb23e8de36c88677d772946e61f7285892f7554e37bd2bca76
diff --git a/net-print/cups/cups-1.4.6-r1.ebuild b/net-print/cups/cups-1.4.6-r1.ebuild
index 3fd3f06..d49c134 100644
--- a/net-print/cups/cups-1.4.6-r1.ebuild
+++ b/net-print/cups/cups-1.4.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.4.6-r1.ebuild,v 1.4 2011/05/01 15:15:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.4.6-r21.ebuild,v 1.2 2011/06/06 21:54:07 dilfridge Exp $
EAPI=3
@@ -81,6 +81,17 @@ pkg_setup() {
python_pkg_setup
fi
+ if use usb; then
+ elog "You are going to use new libusb backed to access your usb printer."
+ elog "This interface has quite few known issues and does not report all"
+ elog "issues and just refuses to print."
+ elog "Please consider disabling usb useflag if you are having issues."
+ elog
+ elog "Please note that if you disable the usb useflag your device will be"
+ elog "still working using kernel usblp interface instead of libusb."
+ echo
+ fi
+
linux-info_pkg_setup
if ! linux_config_exists; then
ewarn "Can't check the linux kernel configuration."
@@ -89,9 +100,7 @@ pkg_setup() {
# recheck that we don't have usblp to collide with libusb
if use usb; then
if linux_chkconfig_present USB_PRINTER; then
- eerror "Your usb printers will be managed via libusb."
- eerror "Note that this interface still has issues so alternatively"
- eerror "you should just disable usb useflag on ${P}."
+ eerror "Your usb printers will be managed via libusb which collides with kernel module."
eerror "${P} requires the USB_PRINTER support disabled."
eerror "Please disable it:"
eerror " CONFIG_USB_PRINTER=n"
@@ -99,6 +108,7 @@ pkg_setup() {
eerror " Device Drivers --->"
eerror " USB support --->"
eerror " [ ] USB Printer support"
+ eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
die "USB_PRINTER module enabled"
fi
else
@@ -112,6 +122,7 @@ pkg_setup() {
ewarn " Device Drivers --->"
ewarn " USB support --->"
ewarn " [*] USB Printer support"
+ ewarn "Alternatively, enable the usb useflag for cups and use the new, less-tested libusb code."
fi
fi
fi
@@ -128,6 +139,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-1.4.4-perl-includes.patch"
epatch "${FILESDIR}/${PN}-1.4.6-force-gnutls.patch"
epatch "${FILESDIR}/${PN}-1.4.6-serialize-gnutls.patch"
+ # interface hangs using some browsers, bug #325871
+ epatch "${FILESDIR}/${PN}-1.4.6-web-hang.patch"
# Dan's group fix
epatch "${FILESDIR}/${PN}-1.4.1-group_fix.patch"
@@ -158,6 +171,16 @@ src_configure() {
"
fi
+ # bug 352252, recheck for later versions if still necessary....
+ if use gnutls && ! use threads ; then
+ ewarn "The useflag gnutls requires also threads enabled. Switching on threads."
+ fi
+ if use gnutls || use threads ; then
+ myconf+=" --enable-threads "
+ else
+ myconf+=" --disable-threads "
+ fi
+
econf \
--libdir=/usr/$(get_libdir) \
--localstatedir=/var \
@@ -178,7 +201,6 @@ src_configure() {
$(use_enable png) \
$(use_enable slp) \
$(use_enable static-libs static) \
- $(use_enable threads) \
$(use_enable tiff) \
$(use_enable usb libusb) \
$(use_with java) \
@@ -274,15 +296,4 @@ pkg_postinst() {
elog "For information about installing a printer and general cups setup"
elog "take a look at: http://www.gentoo.org/doc/en/printing-howto.xml"
echo
-
- if use usb; then
- elog
- elog "You are going to use new libusb backed to access your usb printer."
- elog "This interface has quite few known issues and does not report all"
- elog "issues and just refuses to print."
- elog "Please consider disabling usb useflag if you are having issues."
- elog
- elog "Please note that if you disable the usb useflag your device will be"
- elog "still working using kernel usblp interface instead of libusb."
- fi
}
diff --git a/net-print/cups/cups-1.4.6-r21.ebuild b/net-print/cups/cups-1.4.6-r21.ebuild
new file mode 100644
index 0000000..6d4343a
--- /dev/null
+++ b/net-print/cups/cups-1.4.6-r21.ebuild
@@ -0,0 +1,296 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.4.6-r21.ebuild,v 1.2 2011/06/06 21:54:07 dilfridge Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit autotools eutils flag-o-matic linux-info multilib pam perl-module python versionator java-pkg-opt-2
+
+MY_P=${P/_}
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="http://www.cups.org/"
+SRC_URI="mirror://easysw/${PN}/${PV}/${MY_P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="acl dbus debug gnutls java +jpeg kerberos ldap pam perl php +png python samba slp +ssl static-libs +threads +tiff usb X xinetd"
+
+LANGS="da de es eu fi fr id it ja ko nl no pl pt pt_BR ru sv zh zh_TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="
+ app-text/libpaper
+ acl? (
+ kernel_linux? (
+ sys-apps/acl
+ sys-apps/attr
+ )
+ )
+ dbus? ( sys-apps/dbus )
+ java? ( >=virtual/jre-1.6 )
+ jpeg? ( virtual/jpeg:0 )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap[ssl?,gnutls?] )
+ pam? ( virtual/pam )
+ perl? ( dev-lang/perl )
+ php? ( dev-lang/php )
+ png? ( >=media-libs/libpng-1.4.3 )
+ slp? ( >=net-libs/openslp-1.0.4 )
+ ssl? (
+ gnutls? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )
+ !gnutls? ( >=dev-libs/openssl-0.9.8g )
+ )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ usb? ( virtual/libusb:0 )
+ X? ( x11-misc/xdg-utils )
+ xinetd? ( sys-apps/xinetd )
+ !net-print/cupsddk
+"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+"
+
+PDEPEND="
+ app-text/ghostscript-gpl[cups]
+ >=app-text/poppler-0.12.3-r3[utils]
+"
+
+# upstream includes an interactive test which is a nono for gentoo.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup lp
+ enewuser lp -1 -1 -1 lp
+ enewgroup lpadmin 106
+
+ # python 3 is no-go
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ if use usb; then
+ elog "You are going to use new libusb backed to access your usb printer."
+ elog "This interface has quite few known issues and does not report all"
+ elog "issues and just refuses to print."
+ elog "Please consider disabling usb useflag if you are having issues."
+ elog
+ elog "Please note that if you disable the usb useflag your device will be"
+ elog "still working using kernel usblp interface instead of libusb."
+ echo
+ fi
+
+ linux-info_pkg_setup
+ if ! linux_config_exists; then
+ ewarn "Can't check the linux kernel configuration."
+ ewarn "You might have some incompatible options enabled."
+ else
+ # recheck that we don't have usblp to collide with libusb
+ if use usb; then
+ if linux_chkconfig_present USB_PRINTER; then
+ eerror "Your usb printers will be managed via libusb which collides with kernel module."
+ eerror "${P} requires the USB_PRINTER support disabled."
+ eerror "Please disable it:"
+ eerror " CONFIG_USB_PRINTER=n"
+ eerror "in /usr/src/linux/.config or"
+ eerror " Device Drivers --->"
+ eerror " USB support --->"
+ eerror " [ ] USB Printer support"
+ eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
+ die "USB_PRINTER module enabled"
+ fi
+ else
+ #here we should warn user that he should enable it so he can print
+ if ! linux_chkconfig_present USB_PRINTER; then
+ ewarn "If you plan to use USB printers you should enable the USB_PRINTER"
+ ewarn "support in your kernel."
+ ewarn "Please enable it:"
+ ewarn " CONFIG_USB_PRINTER=y"
+ ewarn "in /usr/src/linux/.config or"
+ ewarn " Device Drivers --->"
+ ewarn " USB support --->"
+ ewarn " [*] USB Printer support"
+ ewarn "Alternatively, enable the usb useflag for cups and use the new, less-tested libusb code."
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ # create a missing symlink to allow https printing via IPP, bug #217293
+ epatch "${FILESDIR}/${PN}-1.4.0-backend-https.patch"
+ # various build time fixes
+ epatch "${FILESDIR}/${PN}-1.4.4-dont-compress-manpages.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-fix-install-perms.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-php-destdir.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-perl-includes.patch"
+ epatch "${FILESDIR}/${PN}-1.4.6-force-gnutls.patch"
+ epatch "${FILESDIR}/${PN}-1.4.6-serialize-gnutls.patch"
+ # interface hangs using some browsers, bug #325871
+ epatch "${FILESDIR}/${PN}-1.4.6-web-hang.patch"
+
+ AT_M4DIR=config-scripts eaclocal
+ eautoconf
+}
+
+src_configure() {
+ export DSOFLAGS="${LDFLAGS}"
+
+ # locale support
+ strip-linguas ${LANGS}
+ if [ -z "${LINGUAS}" ] ; then
+ export LINGUAS=none
+ fi
+
+ local myconf
+ if use ssl || use gnutls ; then
+ myconf+="
+ $(use_enable gnutls)
+ $(use_enable !gnutls openssl)
+ "
+ else
+ myconf+="
+ --disable-gnutls
+ --disable-openssl
+ "
+ fi
+
+ # bug 352252, recheck for later versions if still necessary....
+ if use gnutls && ! use threads ; then
+ ewarn "The useflag gnutls requires also threads enabled. Switching on threads."
+ fi
+ if use gnutls || use threads ; then
+ myconf+=" --enable-threads "
+ else
+ myconf+=" --disable-threads "
+ fi
+
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ --with-cups-user=lp \
+ --with-cups-group=lp \
+ --with-docdir=/usr/share/cups/html \
+ --with-languages="${LINGUAS}" \
+ --with-pdftops=/usr/bin/pdftops \
+ --with-system-groups=lpadmin \
+ $(use_enable acl) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable debug debug-guards) \
+ $(use_enable jpeg) \
+ $(use_enable kerberos gssapi) \
+ $(use_enable ldap) \
+ $(use_enable pam) \
+ $(use_enable png) \
+ $(use_enable slp) \
+ $(use_enable static-libs static) \
+ $(use_enable tiff) \
+ $(use_enable usb libusb) \
+ $(use_with java) \
+ $(use_with perl) \
+ $(use_with php) \
+ $(use_with python) \
+ $(use_with xinetd xinetd /etc/xinetd.d) \
+ --enable-libpaper \
+ --disable-dnssd \
+ ${myconf}
+
+ # install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # makes more sense when facing multilib support.
+ sed -i -e 's:SERVERBIN.*:SERVERBIN = "$(BUILDROOT)"/usr/libexec/cups:' Makedefs || die
+ sed -i -e 's:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN "/usr/libexec/cups":' config.h || die
+ sed -i -e 's:cups_serverbin=.*:cups_serverbin=/usr/libexec/cups:' cups-config || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use perl ; then
+ cd "${S}"/scripting/perl
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+
+ if use php ; then
+ cd "${S}"/scripting/php
+ emake || die "emake php failed"
+ fi
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install || die "emake install failed"
+ dodoc {CHANGES,CREDITS,README}.txt || die "dodoc install failed"
+
+ if use perl ; then
+ cd "${S}"/scripting/perl
+ perl-module_src_install
+ fixlocalpod
+ fi
+
+ if use php ; then
+ cd "${S}"/scripting/php
+ emake DESTDIR="${D}" install || die "emake install for php bindings failed"
+ fi
+
+ # clean out cups init scripts
+ rm -rf "${D}"/etc/{init.d/cups,rc*,pam.d/cups}
+
+ # install our init script
+ local neededservices
+ use dbus && neededservices+=" dbus"
+ [[ -n ${neededservices} ]] && neededservices="need${neededservices}"
+ cp "${FILESDIR}"/cupsd.init.d "${T}"/cupsd || die
+ sed -i \
+ -e "s/@neededservices@/$neededservices/" \
+ "${T}"/cupsd || die
+ doinitd "${T}"/cupsd || die "doinitd failed"
+
+ # install our pam script
+ pamd_mimic_system cups auth account
+
+ if use xinetd ; then
+ # correct path
+ sed -i \
+ -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" \
+ "${D}"/etc/xinetd.d/cups-lpd || die
+ # it is safer to disable this by default, bug #137130
+ grep -w 'disable' "${D}"/etc/xinetd.d/cups-lpd || \
+ { sed -i -e "s:}:\tdisable = yes\n}:" "${D}"/etc/xinetd.d/cups-lpd || die ; }
+ # write permission for file owner (root), bug #296221
+ fperms u+w /etc/xinetd.d/cups-lpd || die "fperms failed"
+ else
+ rm -rf "${D}"/etc/xinetd.d
+ fi
+
+ keepdir /usr/libexec/cups/driver /usr/share/cups/{model,profiles} \
+ /var/cache/cups /var/cache/cups/rss /var/log/cups /var/run/cups/certs \
+ /var/spool/cups/tmp
+
+ keepdir /etc/cups/{interfaces,ppd,ssl}
+
+ use X || rm -r "${D}"/usr/share/applications
+
+ # create /etc/cups/client.conf, bug #196967 and #266678
+ echo "ServerName /var/run/cups/cups.sock" >> "${D}"/etc/cups/client.conf
+}
+
+pkg_postinst() {
+ echo
+ elog "For information about installing a printer and general cups setup"
+ elog "take a look at: http://www.gentoo.org/doc/en/printing-howto.xml"
+ echo
+}