summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh-run-help/zsh-run-help-1.ebuild')
-rw-r--r--app-shells/zsh-run-help/zsh-run-help-1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-shells/zsh-run-help/zsh-run-help-1.ebuild b/app-shells/zsh-run-help/zsh-run-help-1.ebuild
index 073b277d..eaa125e3 100644
--- a/app-shells/zsh-run-help/zsh-run-help-1.ebuild
+++ b/app-shells/zsh-run-help/zsh-run-help-1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header $
EAPI="4"
+inherit base
DESCRIPTION="Directory of help-files (for run-help) for your current zsh"
HOMEPAGE=""
@@ -24,7 +25,7 @@ src_unpack() {
mkdir "${S}"
}
-src_compile() {
+src_prepare() {
local help i mystatus
# We need GROFF_NO_SGR to produce "classical" formatting:
export GROFF_NO_SGR=''
@@ -50,6 +51,7 @@ src_compile() {
eerror "For compatibility reasons, this ebuild ignores LC_ALL."
die "Failed to produce necessary files"
}
+ base_src_prepare
}
src_install() {