summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-01-18 10:05:57 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:21 +0200
commit4c35eac8337e75eb4950937173a434a818bb28aa (patch)
treef945ad02bd1d1ffe7b991fb6aebfb6cff013f823 /dev-util
parentBump zram-init (diff)
downloadmv-4c35eac8337e75eb4950937173a434a818bb28aa.tar.gz
mv-4c35eac8337e75eb4950937173a434a818bb28aa.tar.bz2
mv-4c35eac8337e75eb4950937173a434a818bb28aa.zip
Fix python dependencies and re-add arches, making repoman happy
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/ccache-99999999-r3.ebuild11
-rw-r--r--dev-util/pyrep/ChangeLog7
-rw-r--r--dev-util/pyrep/pyrep-1.4-r1.ebuild (renamed from dev-util/pyrep/pyrep-1.4.ebuild)6
3 files changed, 16 insertions, 8 deletions
diff --git a/dev-util/ccache/ccache-99999999-r3.ebuild b/dev-util/ccache/ccache-99999999-r3.ebuild
index 811a0952..99842099 100644
--- a/dev-util/ccache/ccache-99999999-r3.ebuild
+++ b/dev-util/ccache/ccache-99999999-r3.ebuild
@@ -11,6 +11,7 @@ inherit autotools eutils git-r3 readme.gentoo
DESCRIPTION="fast compiler cache"
HOMEPAGE="http://ccache.samba.org/"
+SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
@@ -41,13 +42,13 @@ src_install() {
DOC_CONTENTS="
To use ccache with **non-Portage** C compiling, add
-${EPREFIX}/usr/lib/ccache/bin to the beginning of your path, before ${EPREFIX}usr/bin.
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before '${EPREFIX}/usr/bin'.
Portage 2.0.46-r11+ will automatically take advantage of ccache with
no additional steps. If this is your first install of ccache, type
-something like this to set a maximum cache size of 2GB:\\n
-# ccache -M 2G\\n
-If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
-# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+something like this to set a maximum cache size of 2GB:
+# ccache -M 2G
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C
ccache now supports sys-devel/clang and dev-lang/icc, too!"
readme.gentoo_create_doc
diff --git a/dev-util/pyrep/ChangeLog b/dev-util/pyrep/ChangeLog
index 3ee79ffe..03d515b6 100644
--- a/dev-util/pyrep/ChangeLog
+++ b/dev-util/pyrep/ChangeLog
@@ -2,7 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*pyrep-1.4 (10 Aug 2043)
+*pyrep-1.4-r1 (18 Jan 2015)
+
+ 18 Jan 2015; Martin Väth <martin@mvath.de>:
+ Use new-style python dependency
+
+*pyrep-1.4 (10 Aug 2014)
10 Aug 2014; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild
diff --git a/dev-util/pyrep/pyrep-1.4.ebuild b/dev-util/pyrep/pyrep-1.4-r1.ebuild
index 24589512..71807f45 100644
--- a/dev-util/pyrep/pyrep-1.4.ebuild
+++ b/dev-util/pyrep/pyrep-1.4-r1.ebuild
@@ -4,7 +4,8 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils
+PYTHON_COMPAT=( jython2_{5,7} pypy{,3} python{2_7,3_{3,4}} )
+inherit eutils python-r1
DESCRIPTION="Search and/or replace regular expressions within many files interactively"
HOMEPAGE="https://github.com/vaeth/pyrep/"
@@ -15,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-lang/python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
src_prepare() {
use prefix || sed -i \