summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-03-15 22:28:09 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:21 +0200
commit83961f4c76a0de435f074a1173367e1eda97dbf5 (patch)
treebc87aef66e3222a856d7a2f73adf13ad62892666
parentBump less, sundtek-tv, noscript (diff)
downloadmv-83961f4c76a0de435f074a1173367e1eda97dbf5.tar.gz
mv-83961f4c76a0de435f074a1173367e1eda97dbf5.tar.bz2
mv-83961f4c76a0de435f074a1173367e1eda97dbf5.zip
bump squashmount, noscript. video-mv: deprecate mplayer2
-rw-r--r--media-video/video-mv/ChangeLog5
-rw-r--r--media-video/video-mv/video-mv-7.17-r1.ebuild64
-rw-r--r--sys-fs/squashmount/ChangeLog5
-rw-r--r--sys-fs/squashmount/Manifest2
-rw-r--r--sys-fs/squashmount/squashmount-10.0.0.ebuild (renamed from sys-fs/squashmount/squashmount-9.0.1.ebuild)0
-rw-r--r--www-plugins/noscript/ChangeLog5
-rw-r--r--www-plugins/noscript/Manifest2
-rw-r--r--www-plugins/noscript/noscript-2.6.9.18.ebuild (renamed from www-plugins/noscript/noscript-2.6.9.17.ebuild)0
8 files changed, 81 insertions, 2 deletions
diff --git a/media-video/video-mv/ChangeLog b/media-video/video-mv/ChangeLog
index 50aad2e8..d52d9127 100644
--- a/media-video/video-mv/ChangeLog
+++ b/media-video/video-mv/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*video-mv-7.17-r1 (15 Mar 2015)
+
+ 15 Mar 2014; Martin Väth <martin@mvath.de>:
+ Remove *mplayer2, since its support is deprecated in gentoo
+
*video-mv-7.17 (18 Aug 2014)
18 Aug 2014; Martin Väth <martin@mvath.de>:
diff --git a/media-video/video-mv/video-mv-7.17-r1.ebuild b/media-video/video-mv/video-mv-7.17-r1.ebuild
new file mode 100644
index 00000000..081fa933
--- /dev/null
+++ b/media-video/video-mv/video-mv-7.17-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo
+
+DESCRIPTION="Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder"
+HOMEPAGE="https://github.com/vaeth/video-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-shells/push
+ >=app-shells/runtitle-2.3
+ || ( ( media-sound/alsa-utils
+ || ( media-video/mplayer[encode] virtual/ffmpeg ) )
+ media-tv/linuxtv-dvb-apps )"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="If you use dvb-t with zsh completion, you might want to put
+zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'
+into your ~/.zshrc or /etc/zshrc for case-insensitive matching."
+
+src_prepare() {
+ local i
+ use prefix || for i in bin/*
+ do test -h "${i}" || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e 's"^\. _videoscript\.sh$". '"${EPREFIX}/usr/share/video-mv/_videoscript.sh"'"' \
+ -- "${i}" || die
+ done
+ rm bin/*mplayer2*
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}"
+ then doins "${i}"
+ elif [ "${i#*/}" != '_videoscript.sh' ]
+ then dobin "${i}"
+ fi
+ done
+ insinto /usr/share/video-mv
+ doins bin/_videoscript.sh
+ insinto /etc
+ doins etc/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "status bar support" app-shells/runtitle
+ readme.gentoo_pkg_postinst
+}
diff --git a/sys-fs/squashmount/ChangeLog b/sys-fs/squashmount/ChangeLog
index 07fcb96d..06ebe0f6 100644
--- a/sys-fs/squashmount/ChangeLog
+++ b/sys-fs/squashmount/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*squashmount-10.0.0 (15 Mar 2015)
+
+ 15 Mar 2015; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
*squashmount-9.0.1 (25 Dec 2014)
27 Dec 2014; Martin Väth <martin@mvath.de>:
diff --git a/sys-fs/squashmount/Manifest b/sys-fs/squashmount/Manifest
index c4f412b2..087bcbe7 100644
--- a/sys-fs/squashmount/Manifest
+++ b/sys-fs/squashmount/Manifest
@@ -1 +1 @@
-DIST squashmount-v9.0.1.tar.gz 53579 SHA256 b40c0ff3736ae4f3ebe5f9520ebe8654d9527a8b927327994d7ac9ec67f86aa2 SHA512 8b4a51986821731fdd10135e3888f7bd22d93fd1efefd8cf5ad91cde3e00e3e6b252915b54ea2427e865a9e83f3dd7b517b98e1536c14da49ba1b05582816868 WHIRLPOOL 6263435bc34b8ea873d9a6ff680f7fcf9980cbb53d6e5eba18061c5943184394416d37dd43c79b0e184430474bb14f8469979b38021a2399e6b24aa157d78695
+DIST squashmount-v10.0.0.tar.gz 56958 SHA256 2f6168346a7f2095a72004d93c241736fe8f119ed1d8b85f694f85a5c526069b SHA512 5bac36be715a084218e442bded0570ba57d9b0891cf80e0c8b60f2bd2d3b1851dc118737df680781daf3559c8ad7aad22dd7ff17c234e26e13fc0c68a7ded452 WHIRLPOOL 1ffeba6be96bf9a8ca479d7023161e52db2f2600046817c4b64bb39a056f3b931f960b5611e528bc6260ef59e34faa7ae1c1e1aeb7778efec2bc09ffe430a952
diff --git a/sys-fs/squashmount/squashmount-9.0.1.ebuild b/sys-fs/squashmount/squashmount-10.0.0.ebuild
index 98bc26ff..98bc26ff 100644
--- a/sys-fs/squashmount/squashmount-9.0.1.ebuild
+++ b/sys-fs/squashmount/squashmount-10.0.0.ebuild
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
index c10b27da..5aedf5dd 100644
--- a/www-plugins/noscript/ChangeLog
+++ b/www-plugins/noscript/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*noscript-2.6.9.18 (15 Mar 2015)
+
+ 15 Mar 2015; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
*noscript-2.6.9.17 (10 Mar 2015)
10 Mar 2015; Martin Väth <martin@mvath.de>:
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
index 58f16e07..a05cc6d9 100644
--- a/www-plugins/noscript/Manifest
+++ b/www-plugins/noscript/Manifest
@@ -1 +1 @@
-DIST noscript-2.6.9.17.xpi 546141 SHA256 9e4308cdb9e21bfce58e7b16bad1c30be4c53a1b6131f01fe722c03893af24bb SHA512 dd4a1e0a67fbca954b96af5a8bdc2c5a3d57624c1e30f744faaa71f765eef591bd6ff06b097218dc35083b9bc1a59e87aa3f2426f45e3be4c30a19c258576fa9 WHIRLPOOL b3bde2ea374aa2373738d67a4d831ab9a59253b5c4153258ee9dbb8ace0eab382c6f3cbcd924be1263b1866ef9f358bbcef3a340fa9b5774894bab52e82cbeee
+DIST noscript-2.6.9.18.xpi 546339 SHA256 3adc5f5796678fba58f0688e07254b4aa933980e68498cc21b2aabcd1a2d4e90 SHA512 3448c3ff7b2854c0531e4ef67343a31a63b689ded9f531708e96922275ebe33f886ae731544d4fbacd92fb1d92721a4254e8fd03d4c3506761cea0d9b97bb786 WHIRLPOOL 6562dfccfeaade740d375734c8ceb6b42a1629de6322654a22d5639b093251bbb0d81a3521a423d7add53291654aa652dc7eac4c49d7e101a1e7c45b72b47d83
diff --git a/www-plugins/noscript/noscript-2.6.9.17.ebuild b/www-plugins/noscript/noscript-2.6.9.18.ebuild
index 82dc8b3b..82dc8b3b 100644
--- a/www-plugins/noscript/noscript-2.6.9.17.ebuild
+++ b/www-plugins/noscript/noscript-2.6.9.18.ebuild