summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-06-08 12:30:49 +0200
committerMartin Väth <martin@mvath.de>2018-06-08 12:30:49 +0200
commit7c62fc3dd6f95c909bbec0739abbb3a370c13308 (patch)
tree692012d235aad66e804ca07ae3a21808397e30ca
parentapp-shells/set_prompt: Version bump (diff)
downloadmv-7c62fc3dd6f95c909bbec0739abbb3a370c13308.tar.gz
mv-7c62fc3dd6f95c909bbec0739abbb3a370c13308.tar.bz2
mv-7c62fc3dd6f95c909bbec0739abbb3a370c13308.zip
EAPI=7 version bumps
-rw-r--r--app-portage/getdelta/getdelta-0.7.9-r2.ebuild12
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.18.ebuild2
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild4
-rw-r--r--app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild15
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-4.7-r1.ebuild2
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild14
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild14
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild14
-rw-r--r--dev-libs/weston/weston-3.0.0.ebuild7
-rw-r--r--media-video/video-mv/video-mv-13.0.ebuild15
10 files changed, 49 insertions, 50 deletions
diff --git a/app-portage/getdelta/getdelta-0.7.9-r2.ebuild b/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
index d9f35365..e1935069 100644
--- a/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
+++ b/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
DESCRIPTION="dynamic deltup client"
@@ -16,11 +16,6 @@ S="${WORKDIR}"
RDEPEND="app-portage/deltup
dev-util/bdelta"
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="You need to put
-FETCHCOMMAND=\"/usr/bin/getdelta.sh \\\"\\\${URI}\\\" \\\"\\\${FILE}\\\"\"
-into your /etc/make.conf to make use of getdelta"
-
src_prepare() {
eapply "${FILESDIR}/eapi2.patch"
sed -i -e "s:/bin/sh:/bin/bash:" getdelta.sh || die
@@ -28,7 +23,12 @@ src_prepare() {
}
src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS
dobin "${WORKDIR}"/getdelta.sh
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="You need to put
+FETCHCOMMAND=\"/usr/bin/getdelta.sh \\\"\\\${URI}\\\" \\\"\\\${FILE}\\\"\"
+into your /etc/make.conf to make use of getdelta"
readme.gentoo_create_doc
}
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.18.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.18.ebuild
index b777c33e..8af368de 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.18.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
index 2ae32f84..8af368de 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
@@ -19,7 +19,7 @@ case ${PV} in
SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
- SRC_URI="https://github.com/zdharma/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
+ SRC_URI="https://github.com/zdharma/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz";;
esac
DESCRIPTION="Optimized and extended zsh-syntax-highlighting"
diff --git a/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild b/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
index 0ac77d3a..7d74b7ba 100644
--- a/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
+++ b/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://github.com/robbyrussell/${PN}.git"
inherit git-r3 readme.gentoo-r1
@@ -22,12 +22,6 @@ ZSH_DEST="/usr/share/zsh/site-contrib/${PN}"
ZSH_EDEST="${EPREFIX}${ZSH_DEST}"
ZSH_TEMPLATE="templates/zshrc.zsh-template"
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add to your ~/.zshrc
-source '${ZSH_DEST}/${ZSH_TEMPLATE}'
-or copy a modification of that file to your ~/.zshrc
-If you just want to try, enter the above command in your zsh."
-
src_prepare() {
local i
for i in "${S}"/tools/*install* "${S}"/tools/*upgrade*
@@ -42,8 +36,15 @@ src_prepare() {
}
src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS
insinto "${ZSH_DEST}"
doins -r *
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add to your ~/.zshrc
+source '${ZSH_DEST}/${ZSH_TEMPLATE}'
+or copy a modification of that file to your ~/.zshrc
+If you just want to try, enter the above command in your zsh."
+
readme.gentoo_create_doc
}
diff --git a/app-shells/termcolors-mv/termcolors-mv-4.7-r1.ebuild b/app-shells/termcolors-mv/termcolors-mv-4.7-r1.ebuild
index 9cc0d593..12b77da7 100644
--- a/app-shells/termcolors-mv/termcolors-mv-4.7-r1.ebuild
+++ b/app-shells/termcolors-mv/termcolors-mv-4.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 2013-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
inherit readme.gentoo-r1
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
index ffc7617b..e28aceb3 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
@@ -32,12 +32,6 @@ IUSE=""
RDEPEND="app-shells/zsh"
DEPEND=""
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
-. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
-at the end of your ~/.zshrc
-For testing, you can also execute the above command in your zsh."
-
MAKE_ARGS=(
"SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
"DOC_DIR=${ED}/usr/share/doc/${PF}"
@@ -56,7 +50,13 @@ src_compile() {
}
src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS
emake "${MAKE_ARGS[@]}" install
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
readme.gentoo_create_doc
}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
index ffc7617b..e28aceb3 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
@@ -1,7 +1,7 @@
# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
@@ -32,12 +32,6 @@ IUSE=""
RDEPEND="app-shells/zsh"
DEPEND=""
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
-. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
-at the end of your ~/.zshrc
-For testing, you can also execute the above command in your zsh."
-
MAKE_ARGS=(
"SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
"DOC_DIR=${ED}/usr/share/doc/${PF}"
@@ -56,7 +50,13 @@ src_compile() {
}
src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS
emake "${MAKE_ARGS[@]}" install
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
readme.gentoo_create_doc
}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
index ffc7617b..e28aceb3 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
@@ -32,12 +32,6 @@ IUSE=""
RDEPEND="app-shells/zsh"
DEPEND=""
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
-. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
-at the end of your ~/.zshrc
-For testing, you can also execute the above command in your zsh."
-
MAKE_ARGS=(
"SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
"DOC_DIR=${ED}/usr/share/doc/${PF}"
@@ -56,7 +50,13 @@ src_compile() {
}
src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS
emake "${MAKE_ARGS[@]}" install
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
readme.gentoo_create_doc
}
diff --git a/dev-libs/weston/weston-3.0.0.ebuild b/dev-libs/weston/weston-3.0.0.ebuild
index 599b42f0..c55bc4ee 100644
--- a/dev-libs/weston/weston-3.0.0.ebuild
+++ b/dev-libs/weston/weston-3.0.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/weston.git"
@@ -81,9 +81,8 @@ RDEPEND="
x11-libs/libXcursor
)
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
eapply "${FILESDIR}"/pam.patch
diff --git a/media-video/video-mv/video-mv-13.0.ebuild b/media-video/video-mv/video-mv-13.0.ebuild
index 437e4de5..8d136922 100644
--- a/media-video/video-mv/video-mv-13.0.ebuild
+++ b/media-video/video-mv/video-mv-13.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2012-2017 Gentoo Foundation
+# Copyright 2012-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
inherit readme.gentoo-r1
@@ -25,11 +25,6 @@ RDEPEND=">=app-shells/push-2.0-r2
${OPTIONAL_RDEPEND}"
DEPEND=""
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="If you use dvb-t with zsh completion, you might want to put
-zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'
-into your ~/.zshrc or /etc/zshrc for case-insensitive matching."
-
src_prepare() {
local i
use prefix || for i in bin/*
@@ -42,7 +37,7 @@ src_prepare() {
}
src_install() {
- local i
+ local i DISABLE_AUTOFORMATTING DOC_CONTENTS
insinto /usr/bin
for i in bin/*
do if test -h "${i}"
@@ -58,6 +53,10 @@ src_install() {
insinto /usr/share/zsh/site-functions
doins zsh/*
dodoc README.md
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="If you use dvb-t with zsh completion, you might want to put
+zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'
+into your ~/.zshrc or /etc/zshrc for case-insensitive matching."
readme.gentoo_create_doc
}