summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/polygon/polygon-3.0.4a.ebuild')
-rw-r--r--dev-python/polygon/polygon-3.0.4a.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/polygon/polygon-3.0.4a.ebuild b/dev-python/polygon/polygon-3.0.4a.ebuild
new file mode 100644
index 0000000..978434b
--- /dev/null
+++ b/dev-python/polygon/polygon-3.0.4a.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Polygon is a python package that handles polygonal shapes in 2D."
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://github.com/downloads/jraedler/Polygon3/Polygon-${PV}-src.zip"
+
+LICENSE="LGPL"
+SLOT="3"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Polygon-${PV/a/}"