aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/golang-single.eclass9
-rw-r--r--eclass/qt4-r2.eclass139
-rw-r--r--x11-misc/x11vnc/Manifest5
-rw-r--r--x11-misc/x11vnc/files/x11vnc.conf.d37
-rw-r--r--x11-misc/x11vnc/files/x11vnc.init.d70
-rw-r--r--x11-misc/x11vnc/metadata.xml21
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.15.ebuild55
7 files changed, 2 insertions, 334 deletions
diff --git a/eclass/golang-single.eclass b/eclass/golang-single.eclass
index 3440bc8..4f98898 100644
--- a/eclass/golang-single.eclass
+++ b/eclass/golang-single.eclass
@@ -24,7 +24,7 @@
# GOLANG_PKG_IMPORTPATH="github.com/captObvious"
# GOLANG_PKG_ARCHIVESUFFIX=".zip"
# GOLANG_PKG_HAVE_TEST
-# inherit golang-single qt4-r2
+# inherit golang-single
#
# DESCRIPTION="Foo bar application"
# HOMEPAGE="http://example.org/foo/"
@@ -32,13 +32,9 @@
# LICENSE="MIT"
# KEYWORDS="~amd64 ~x86"
# SLOT="0"
-# IUSE="doc qt4"
+# IUSE="doc"
#
# CDEPEND="
-# qt4? (
-# dev-qt/qtcore:4
-# dev-qt/qtgui:4
-# )"
# RDEPEND="${CDEPEND}
# !media-gfx/bar"
# DEPEND="${CDEPEND}
@@ -47,7 +43,6 @@
# DOCS=(AUTHORS ChangeLog README "Read me.txt" TODO)
#
# PATCHES=(
-# "${FILESDIR}/${P}-qt4.patch" # bug 123458
# "${FILESDIR}/${P}-as-needed.patch"
# )
#
diff --git a/eclass/qt4-r2.eclass b/eclass/qt4-r2.eclass
deleted file mode 100644
index d8a7252..0000000
--- a/eclass/qt4-r2.eclass
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# @ECLASS: qt4-r2.eclass
-# @MAINTAINER:
-# qt@gentoo.org
-# @BLURB: Eclass for Qt4-based packages, second edition.
-# @DESCRIPTION:
-# This eclass contains various functions that may be useful when
-# dealing with packages using Qt4 libraries. Supports only EAPIs
-# 2, 3, 4, and 5. Use qmake-utils.eclass in EAPI 6 and later.
-
-case ${EAPI} in
- 2|3|4|5) : ;;
- 6) die "qt4-r2.eclass is banned in EAPI 6 and later" ;;
- *) die "qt4-r2.eclass: unsupported EAPI=${EAPI:-0}" ;;
-esac
-
-inherit base eutils qmake-utils
-
-export XDG_CONFIG_HOME="${T}"
-
-# @ECLASS-VARIABLE: DOCS
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Array containing documents passed to dodoc command.
-# Paths can be absolute or relative to ${S}.
-#
-# Example: DOCS=( ChangeLog README "${WORKDIR}/doc_folder/" )
-
-# @ECLASS-VARIABLE: HTML_DOCS
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Array containing documents passed to dohtml command.
-# Paths can be absolute or relative to ${S}.
-#
-# Example: HTML_DOCS=( "doc/document.html" "${WORKDIR}/html_folder/" )
-
-# @ECLASS-VARIABLE: LANGS
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# In case your Qt4 application provides various translations, use this variable
-# to specify them in order to populate "linguas_*" IUSE automatically. Make sure
-# that you set this variable before inheriting qt4-r2 eclass.
-#
-# Example: LANGS="de el it ja"
-for x in ${LANGS}; do
- IUSE+=" linguas_${x}"
-done
-
-# @ECLASS-VARIABLE: LANGSLONG
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Same as LANGS, but this variable is for LINGUAS that must be in long format.
-# Remember to set this variable before inheriting qt4-r2 eclass.
-# Look at ${PORTDIR}/profiles/desc/linguas.desc for details.
-#
-# Example: LANGSLONG="en_GB ru_RU"
-for x in ${LANGSLONG}; do
- IUSE+=" linguas_${x%_*}"
-done
-unset x
-
-# @ECLASS-VARIABLE: PATCHES
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Array variable containing all the patches to be applied. This variable
-# is expected to be defined in the global scope of ebuilds. Make sure to
-# specify the full path. This variable is used in src_prepare phase.
-#
-# Example:
-# @CODE
-# PATCHES=(
-# "${FILESDIR}/mypatch.patch"
-# "${FILESDIR}/mypatch2.patch"
-# )
-# @CODE
-
-# @FUNCTION: qt4-r2_src_unpack
-# @DESCRIPTION:
-# Default src_unpack function for packages that depend on qt4. If you have to
-# override src_unpack in your ebuild (probably you don't need to), call
-# qt4-r2_src_unpack in it.
-qt4-r2_src_unpack() {
- debug-print-function $FUNCNAME "$@"
-
- base_src_unpack "$@"
-}
-
-# @FUNCTION: qt4-r2_src_prepare
-# @DESCRIPTION:
-# Default src_prepare function for packages that depend on qt4. If you have to
-# override src_prepare in your ebuild, you should call qt4-r2_src_prepare in it,
-# otherwise autopatcher will not work!
-qt4-r2_src_prepare() {
- debug-print-function $FUNCNAME "$@"
-
- base_src_prepare "$@"
-}
-
-# @FUNCTION: qt4-r2_src_configure
-# @DESCRIPTION:
-# Default src_configure function for packages that depend on qt4. If you have to
-# override src_configure in your ebuild, call qt4-r2_src_configure in it.
-qt4-r2_src_configure() {
- debug-print-function $FUNCNAME "$@"
-
- local project_file=$(qmake-utils_find_pro_file)
-
- if [[ -n ${project_file} ]]; then
- eqmake4 "${project_file}"
- else
- base_src_configure "$@"
- fi
-}
-
-# @FUNCTION: qt4-r2_src_compile
-# @DESCRIPTION:
-# Default src_compile function for packages that depend on qt4. If you have to
-# override src_compile in your ebuild (probably you don't need to), call
-# qt4-r2_src_compile in it.
-qt4-r2_src_compile() {
- debug-print-function $FUNCNAME "$@"
-
- base_src_compile "$@"
-}
-
-# @FUNCTION: qt4-r2_src_install
-# @DESCRIPTION:
-# Default src_install function for qt4-based packages. Installs compiled code,
-# and documentation (via DOCS and HTML_DOCS variables).
-qt4-r2_src_install() {
- debug-print-function $FUNCNAME "$@"
-
- base_src_install INSTALL_ROOT="${D}" "$@"
- einstalldocs
-}
-
-EXPORT_FUNCTIONS src_unpack src_prepare src_configure src_compile src_install
diff --git a/x11-misc/x11vnc/Manifest b/x11-misc/x11vnc/Manifest
deleted file mode 100644
index 2e523b3..0000000
--- a/x11-misc/x11vnc/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX x11vnc.conf.d 1435 BLAKE2B 8403d61a4941c56127e869d6ac90d4f85237af9af786f864d32afbedf3e736528b74c8c83fcf3491794b9e62db6ef2a354dccd61f368c8e9251f915e2bd683f8 SHA512 dedc94fab89a06ca6025b99c2c944cabe77640487c8fc761a6420e5be7062ee4c1c383f3846c17bed434ad4f3ec3b994badb493919acb99da3f61caa40c60246
-AUX x11vnc.init.d 1728 BLAKE2B 45680af6aad530a9b36f29adc61c1f90ad272bd7201c30f29b3d6c5b980012ddb299c878ae1bb20734496c4f2b8b1e1c507cadee875305167e3f298993947a9e SHA512 8de7966b79b5acc83c8cebc3c2ef0819196f5a33eabad619991d04c7c059a68afbf44d0ece6b0db33cea1f525402a601b25db220733f0ff69c0fff48d3c50ac2
-DIST x11vnc-0.9.15.tar.gz 1701821 BLAKE2B b53de9b86c8f9da27388898fe70b6b331a5f00348391f1ccd3c21097a66e967b862ec665f8c9ef9023770a795bb079545012f1f5747fc6d39fda339fcbee9404 SHA512 d5db90f87ba4b9801e8f6bb2c0821657c6388ce2c64e1565aeeabe41edf63b56ad72dc7be4cf874b817dacd7de5988eddd466df5b9396c13d69340ac90a1ca4d
-EBUILD x11vnc-0.9.15.ebuild 1350 BLAKE2B b3cbcb6745630909c620e3cdba5c66416edaa315a893011d02e5bc172d32fc04dded097d0188deffbc143b5f7e1f2b9563375b68cf06980c7a59938203987208 SHA512 9a4b5da0698ea0420ce5f61ec3173cb95551018f0f322e655fe02615f349662638acf746983255cb62e58015707358a9c1dde4acc499f25df42856f78aa830b8
-MISC metadata.xml 694 BLAKE2B c81a1713da2084ad68df6c91b75cba02df7c39950b331916362ffc8dd67b6b72dbf40248c3a906d1f582a8ed5034c4cbebcab7bc4b9db69508a753f44df07102 SHA512 842b0faca49ae6810c42d117ca3f79fc693acfb8a965d3fd2a8c890f475350c29175303f1b56b0c64468dae20e692d2430fc790e7b88165c0f30d65e1bdcb606
diff --git a/x11-misc/x11vnc/files/x11vnc.conf.d b/x11-misc/x11vnc/files/x11vnc.conf.d
deleted file mode 100644
index 7df3a13..0000000
--- a/x11-misc/x11vnc/files/x11vnc.conf.d
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Configuration for running x11vnc as a service. This allows VNC
-# connections prior to logging in to the X display manager.
-
-# Password file location of the password file for VNC Connections
-# Prior to first run, you must configure a password, to do so please
-# run `x11vnc -storepasswd /etc/x11vnc.pass`. Replace /etc/x11vnc.pass
-# ith the location you have specified below
-#X11VNC_RFBAUTH="/etc/x11vnc.pass"
-
-# Port to listen on for incoming connections
-#X11VNC_RFBPORT="5900"
-
-# Automatically probe for a free port to listen on for incoming connections
-# starting from the port number specified
-# Setting this will diable X11VNC_RFBPORT above
-# See `man x11vnc`, option `-autoport` for more information
-#X11VNC_AUTOPORT=""
-
-# X Display to attach to
-# This should match the display your DM is running on
-#X11VNC_DISPLAY=":0"
-
-# Location of the x11vnc logfile
-#X11VNC_LOG="/var/log/x11vnc"
-
-# Miscelaneous options to pass to x11vnc.
-# Do not set options that are configurable above.
-# Check `x11vnc -help` or `man x11vnc` for more options.
-# * Modern composting DMs/WMs will require "-noxdamage"
-# * If you experience crashes on logging in, try "-noxfixes"
-# * Other suggested options include "-noxrecord" and "-ncache ##"
-# Refer to the x11vnc man page for further explanations.
-#X11VNC_OPTS=""
-
diff --git a/x11-misc/x11vnc/files/x11vnc.init.d b/x11-misc/x11vnc/files/x11vnc.init.d
deleted file mode 100644
index b6b16da..0000000
--- a/x11-misc/x11vnc/files/x11vnc.init.d
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="The x11vnc daemon init script"
-
-depend() {
- need net
- need xdm
-}
-
-checkconfig() {
-
- # Set Defaults
- X11VNC_RFBAUTH=${X11VNC_RFBAUTH:-/etc/x11vnc.pass}
- X11VNC_RFBPORT=${X11VNC_RFBPORT:-5900}
- X11VNC_DISPLAY=${X11VNC_DISPLAY:-:0}
- X11VNC_LOG=${X11VNC_LOG:-/var/log/x11vnc}
-
- X11VNC_AUTH="/var/run/x11vnc-${X11VNC_DISPLAY}"
-
- if [ -n "${X11VNC_AUTOPORT}" ]; then
- X11VNC_PORT=""
- fi
-
- if [ ! -f "${X11VNC_RFBAUTH}" -o ! -s "${X11VNC_RFBAUTH}" ]; then
- eerror "VNC Password not set, please set one by running: \`x11vnc -storepasswd ${X11VNC_RFBAUTH}\`"
- return 1
- fi
- checkpath -q -f -m 0600 -o root:root "${X11VNC_RFBAUTH}"
-
- # Attempt to find X-Auth file
- if ! type xauth > /dev/null 2>&1 ||
- ! xauth -f /root/.Xauthority extract - "${X11VNC_DISPLAY}" > "${X11VNC_AUTH}" 2>/dev/null ||
- [ ! -s "${X11VNC_AUTH}" ]; then
- # Let x11vnc guess at auth
- X11VNC_AUTH_OPTS="--env FD_XDM=1 -auth guess"
- else
- # We found the proper auth
- X11VNC_AUTH_OPTS="-auth ${X11VNC_AUTH}"
- fi
-
- if [ ! -f "${X11VNC_AUTH}" ]; then
- eerror "Specified X-Authority file '${X11VNC_AUTH}' not found!"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start \
- --exec /usr/bin/x11vnc -- \
- ${X11VNC_AUTH_OPTS} \
- -rfbauth ${X11VNC_RFBAUTH} \
- ${X11VNC_RFBPORT:+-rfbport} ${X11VNC_RFBPORT} \
- ${X11VNC_AUTOPORT:+-autoport} ${X11VNC_AUTOPORT} \
- -display ${X11VNC_DISPLAY} \
- -o ${X11VNC_LOG} \
- -bg -forever \
- ${X11VNC_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop /usr/bin/x11vnc
- eend $?
-}
diff --git a/x11-misc/x11vnc/metadata.xml b/x11-misc/x11vnc/metadata.xml
deleted file mode 100644
index 5c7cf98..0000000
--- a/x11-misc/x11vnc/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>alex_y_xu@yahoo.ca</email>
- <name>Alex Xu</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription>
- The primary goal of this program is to create a portable and
- simple command-line server utility that allows a VNC viewer
- to connect to an actual X display.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">libvncserver</remote-id>
- <remote-id type="github">LibVNC/x11vnc</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-misc/x11vnc/x11vnc-0.9.15.ebuild b/x11-misc/x11vnc/x11vnc-0.9.15.ebuild
deleted file mode 100644
index d50afe9..0000000
--- a/x11-misc/x11vnc/x11vnc-0.9.15.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools vcs-snapshot
-
-DESCRIPTION="A VNC server for real X displays"
-HOMEPAGE="https://libvnc.github.io/"
-SRC_URI="https://github.com/LibVNC/x11vnc/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt fbcon libressl ssl xinerama zeroconf"
-
-RDEPEND=">=net-libs/libvncserver-0.9.8[ssl?]
- x11-libs/libX11
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- >=x11-libs/libXtst-1.1.0
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )
- xinerama? ( x11-libs/libXinerama )
- zeroconf? ( >=net-dns/avahi-0.6.4 )
-"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- x11-libs/libXt"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # --without-v4l because of missing video4linux 2.x support wrt #389079
- econf \
- $(use_with crypt) \
- $(use_with fbcon fbdev) \
- $(use_with ssl) \
- $(use_with ssl crypto) \
- --without-v4l \
- $(use_with xinerama) \
- $(use_with zeroconf avahi)
-}
-
-src_install() {
- default
- doinitd "${FILESDIR}/x11vnc.init.d"
- doconfd "${FILESDIR}/x11vnc.conf.d"
-}