From cd7afb1b02aa60f6c8c1544034aa6e31c5c9b32c Mon Sep 17 00:00:00 2001
From: Sebastian Pipping <sping@gentoo.org>
Date: Sun, 21 Feb 2016 19:22:05 +0100
Subject: dev-util/debootstrap: Depend on keyrings (bug #387565)

Package-Manager: portage-2.2.27
---
 dev-util/debootstrap/debootstrap-1.0.78-r1.ebuild | 50 +++++++++++++++++++++++
 1 file changed, 50 insertions(+)
 create mode 100644 dev-util/debootstrap/debootstrap-1.0.78-r1.ebuild

(limited to 'dev-util')

diff --git a/dev-util/debootstrap/debootstrap-1.0.78-r1.ebuild b/dev-util/debootstrap/debootstrap-1.0.78-r1.ebuild
new file mode 100644
index 000000000000..803d5e45f7da
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.78-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="http://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+	mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sh ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+	app-arch/dpkg
+	net-misc/wget
+	sys-devel/binutils
+"
+RDEPEND="
+	app-crypt/debian-archive-keyring
+	app-crypt/ubuntu-keyring
+"
+
+DOCS=( TODO debian/changelog )
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+	unpack ${PN}_${PV}.tar.gz
+	cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+	return
+}
+
+src_install() {
+	default
+	doman debootstrap.8
+}
+
+pkg_postinst() {
+	if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+		elog "To check Release files against a keyring"
+		elog " (--keyring=K), please install app-crypt/gnupg."
+	fi
+}
-- 
cgit v1.2.3-65-gdbad