From a34496008026e7995c43675361a2d43145c93cd0 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Wed, 25 May 2022 07:36:13 +0200
Subject: dev-python/pygit2: Bump to 1.9.2
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/pygit2/Manifest            |  1 +
 dev-python/pygit2/pygit2-1.9.2.ebuild | 48 +++++++++++++++++++++++++++++++++++
 2 files changed, 49 insertions(+)
 create mode 100644 dev-python/pygit2/pygit2-1.9.2.ebuild

(limited to 'dev-python/pygit2')

diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index a5fbfe90b855..59030476fafa 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1 +1,2 @@
 DIST pygit2-1.9.1.gh.tar.gz 317487 BLAKE2B 56855e656eafc27f24d8d59a0f21e36c49d292d322e6809257036ec0673f88d3299bca76c8f1c1a16bc79d667f0c6a355467ac5960c9999b11c8eddbf398cec6 SHA512 cfc050ef8cb6af7eace49d2e2ca10c77893abcafa1b319e173d39553e01a595ba084e345dedff22e22806527ecaed5387584f813b30184931820bb2bb1c93e58
+DIST pygit2-1.9.2.gh.tar.gz 750593 BLAKE2B 89eeb56edbb7f823c0439e511e3a525789483a80760f6dcfbbdea7f45f1e16241d9772b54288c0acdb471bfe62a457e8fe82ec520d808d01ee8d079076278761 SHA512 523af14ae418b56efd3c541fb306c3a799224db400053590f1676ace9b53ac4c731a1731081f245cd78ab5d233c9e67fa2e5c13e02b6f62de05123cd47a1a70a
diff --git a/dev-python/pygit2/pygit2-1.9.2.ebuild b/dev-python/pygit2/pygit2-1.9.2.ebuild
new file mode 100644
index 000000000000..803654ff18f9
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.9.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+	https://github.com/libgit2/pygit2/
+	https://pypi.org/project/pygit2/
+"
+SRC_URI="
+	https://github.com/libgit2/pygit2/archive/v${PV}.tar.gz
+		-> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+	=dev-libs/libgit2-1.4*:=
+"
+BDEPEND="
+	>=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+	${DEPEND}
+	${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+	distutils-r1_src_prepare
+
+	# unconditionally prevent it from using network
+	sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+	rm -r pygit2 || die
+	distutils-r1_src_test
+}
-- 
cgit v1.2.3-65-gdbad