From 8f6783a0d99fdc5c8ae7753d3c338eabcfb60a66 Mon Sep 17 00:00:00 2001
From: Pacho Ramos <pacho@gentoo.org>
Date: Sun, 16 Jun 2024 11:30:34 +0200
Subject: app-editors/wxhexeditor: Use wxGTK 3.2

Closes: https://bugs.gentoo.org/929137
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
---
 .../wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch | 31 ++++++++++++++
 app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild | 48 ++++++++++++++++++++++
 2 files changed, 79 insertions(+)
 create mode 100644 app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch
 create mode 100644 app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild

(limited to 'app-editors')

diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch
new file mode 100644
index 000000000000..6bbeb2109a56
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch
@@ -0,0 +1,31 @@
+Description: Fix compatibility with wxWidgets 3.2
+Author: Scott Talbert <swt@techie.net>
+Last-Update: 2022-10-17
+Forwarded: no
+
+--- a/src/HexDialogs.cpp
++++ b/src/HexDialogs.cpp
+@@ -420,7 +420,7 @@ void FindDialog::OnChar( wxKeyEvent& eve
+ 	}
+ 
+ void FindDialog::EventHandler( wxCommandEvent& event ){
+-	WX_CLEAR_ARRAY(parent->HighlightArray )
++	WX_CLEAR_ARRAY(parent->HighlightArray );
+ 	parent->HighlightArray.Shrink();
+ 
+ 	if( event.GetId() == btnFind->GetId())
+--- a/src/HexEditorCtrl/HexEditorCtrl.cpp
++++ b/src/HexEditorCtrl/HexEditorCtrl.cpp
+@@ -64,9 +64,9 @@ HexEditorCtrl::~HexEditorCtrl( void ){
+ 	Dynamic_Disconnector();
+ 	Clear();
+ 
+-	WX_CLEAR_ARRAY(MainTagArray)
+-	WX_CLEAR_ARRAY(HighlightArray)
+-   WX_CLEAR_ARRAY(CompareArray)
++	WX_CLEAR_ARRAY(MainTagArray);
++	WX_CLEAR_ARRAY(HighlightArray);
++	WX_CLEAR_ARRAY(CompareArray);
+ 
+    MainTagArray.Shrink();
+    HighlightArray.Shrink();
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild
new file mode 100644
index 000000000000..40e10aaf5241
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="wxHexEditor"
+WX_GTK_VER=3.2-gtk3
+inherit flag-o-matic toolchain-funcs wxwidgets
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files"
+HOMEPAGE="https://github.com/EUA/wxHexEditor"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-v${PV}-src.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+	app-crypt/mhash
+	dev-libs/udis86
+	x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=(
+	"${FILESDIR}"/${P}-syslibs.patch
+	"${FILESDIR}"/${P}-desktop.patch
+	"${FILESDIR}"/${P}-wx3.2.patch
+)
+
+pkg_pretend() {
+	[[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+	[[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_prepare() {
+	setup-wxwidgets
+	default
+
+	# -Werror=odr, -Werror=lto-type-mismatch
+	# https://bugs.gentoo.org/854414
+	# https://github.com/EUA/wxHexEditor/issues/222
+	filter-lto
+}
-- 
cgit v1.2.3-65-gdbad