From d217b9cb22f991af277e2366205b7531c853221a Mon Sep 17 00:00:00 2001
From: Maciej Barć <xgqt@gentoo.org>
Date: Tue, 21 Nov 2023 10:52:19 +0100
Subject: app-containers/distrobox: bump to 1.6.0.1
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Maciej Barć <xgqt@gentoo.org>
---
 app-containers/distrobox/Manifest                 |  1 +
 app-containers/distrobox/distrobox-1.6.0.1.ebuild | 32 +++++++++++++++++++++++
 2 files changed, 33 insertions(+)
 create mode 100644 app-containers/distrobox/distrobox-1.6.0.1.ebuild

(limited to 'app-containers')

diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index a6c196e16d80..52f2f377f3bd 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,2 +1,3 @@
 DIST distrobox-1.5.0.2.tar.gz 5899915 BLAKE2B 2ab49e09b49dc674e0fdfd2783e4a63f12a9ec954674950c5c6f497500e1b1a6697b7350b7dfd9a246f4d3efe228c7610adde79832b0da13967b88c561186194 SHA512 41f889e8e0c0ce7019d4b1a8c638b8de8260df5c541c4068430580820094ae04b6bd8dd5a6e1a82541daf8c4f5cfed0165dc1a85e01906093d3c1a4d715e23b1
+DIST distrobox-1.6.0.1.tar.gz 6751373 BLAKE2B 9d82f33e15be8a2c17b7716ddbecf4fc533f971924c36ba8fa009dac7a87fbc26075ca98d6c58c5974fa1a02657419f26b415925d71f6577a8897a9e199950fc SHA512 cc7bd42b1c7e198eb255b6bdd90a76fa25700edc274b14379ffe3199c8a8cadc9ab27c94f43ee4a92d270b65df7b04e6c11441eb68456fe7ec3d56b2879534f2
 DIST distrobox-1.6.0.tar.gz 6751299 BLAKE2B bd0edc1fa913450f033de6a78acc7631a714b6f12032f78bd4821ed9366836e94a47220da90167fb5ee0f791341d15f2027259dfc0b581b0c2d1787112b5b65f SHA512 8403349771a4f8705f88e759ff4cbffffaac1197a028a938f072b2e71b115c0cdef958b98ba9bea075feebb34330831b8eaef1aa7df6f942276a2290e4c1b6df
diff --git a/app-containers/distrobox/distrobox-1.6.0.1.ebuild b/app-containers/distrobox/distrobox-1.6.0.1.ebuild
new file mode 100644
index 000000000000..cf9ea7ec09d5
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.6.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+	https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+	SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+		-> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"  # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+	|| (
+		app-containers/docker
+		app-containers/podman
+	)
+"
+
+src_install() {
+	sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+	dodoc *.md
+}
-- 
cgit v1.2.3-65-gdbad