summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdock')
-rw-r--r--x11-misc/xdock/files/xdock-0.3.0-clang16.patch19
-rw-r--r--x11-misc/xdock/xdock-0.3.0-r1.ebuild (renamed from x11-misc/xdock/xdock-0.3.0.ebuild)1
2 files changed, 20 insertions, 0 deletions
diff --git a/x11-misc/xdock/files/xdock-0.3.0-clang16.patch b/x11-misc/xdock/files/xdock-0.3.0-clang16.patch
new file mode 100644
index 000000000000..17db7dbb0433
--- /dev/null
+++ b/x11-misc/xdock/files/xdock-0.3.0-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/871549
+--- a/src/docks/xdcalendar.c
++++ b/src/docks/xdcalendar.c
+@@ -1,2 +1,3 @@
+ #include <xdock.h>
++#include <ctype.h>
+ #include <getopt.h>
+--- a/src/docks/xdmemory.c
++++ b/src/docks/xdmemory.c
+@@ -1,2 +1,3 @@
+ #include <xdock.h>
++#include <ctype.h>
+ #include <getopt.h>
+--- a/src/lib/network.c
++++ b/src/lib/network.c
+@@ -10,2 +10,3 @@
+ # include <fcntl.h>
++# include <unistd.h>
+ # define INVALID_SOCKET -1
diff --git a/x11-misc/xdock/xdock-0.3.0.ebuild b/x11-misc/xdock/xdock-0.3.0-r1.ebuild
index dd2c66023042..4c830a3fe0f3 100644
--- a/x11-misc/xdock/xdock-0.3.0.ebuild
+++ b/x11-misc/xdock/xdock-0.3.0-r1.ebuild
@@ -22,6 +22,7 @@ DOCS=( API AUTHORS ChangeLog README TODO )
PATCHES=(
"${FILESDIR}"/${PN}-0.2.0-ldconfig.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {