summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xauth')
-rw-r--r--x11-apps/xauth/Manifest2
-rw-r--r--x11-apps/xauth/metadata.xml5
-rw-r--r--x11-apps/xauth/xauth-1.0.8.ebuild25
-rw-r--r--x11-apps/xauth/xauth-1.0.9-r1.ebuild35
-rw-r--r--x11-apps/xauth/xauth-1.0.9-r2.ebuild34
-rw-r--r--x11-apps/xauth/xauth-1.0.9.ebuild25
6 files changed, 126 insertions, 0 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
new file mode 100644
index 000000000000..4b37772c7076
--- /dev/null
+++ b/x11-apps/xauth/Manifest
@@ -0,0 +1,2 @@
+DIST xauth-1.0.8.tar.bz2 146794 SHA256 a8696ae7a50c699d5fb3a41408b60d98843d19ea46e9f09e391cb98c8f7fd4f7 SHA512 7eb55ad0db16d6f3146413d47b8d3a7dca4cdefa8d9d1421149bc14fd6a78168c7098f3665a3cb413a76566e4dec1e51ae9372336f9be3370fdd3cb5245489d3 WHIRLPOOL abeead3d9535b4b242ec459fc4386d730838cb8b39428a7128b7865d0a00f01ea000a017371bf930d1c9beb9d273df562fc9948f22c164725ee550ebc623d890
+DIST xauth-1.0.9.tar.bz2 154976 SHA256 56ce1523eb48b1f8a4f4244fe1c3d8e6af1a3b7d4b0e6063582421b0b68dc28f SHA512 e7b8e950a3e9e36131041692a22b2390c75df94fa8b5f4ea2ef2d79778e000865b1b0ec5930612dedb782d451022ee52c7c9a404d249809adb4b905b66f44d0b WHIRLPOOL 16f2686a181281610df55d405738d0a39fd7fa891a58606b13abed3754179802e1b22a938ef43d6d4205dfa8ff7f764f5e1c5323e58bed080ccd33ca4f4f0134
diff --git a/x11-apps/xauth/metadata.xml b/x11-apps/xauth/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-apps/xauth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-apps/xauth/xauth-1.0.8.ebuild b/x11-apps/xauth/xauth-1.0.8.ebuild
new file mode 100644
index 000000000000..dd3b21954662
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_pkg_setup
+}
diff --git a/x11-apps/xauth/xauth-1.0.9-r1.ebuild b/x11-apps/xauth/xauth-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..ed1c75e9277a
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.9-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+# Tests dependend on dev-util/cmdtest awaiting keywording, bug #511202.
+# test? ( dev-util/cmdtest )
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}
diff --git a/x11-apps/xauth/xauth-1.0.9-r2.ebuild b/x11-apps/xauth/xauth-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..ca4a5217f079
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.9-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# Tests dependend on dev-util/cmdtest awaiting keywording, bug #511202.
+# test? ( dev-util/cmdtest )
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}
diff --git a/x11-apps/xauth/xauth-1.0.9.ebuild b/x11-apps/xauth/xauth-1.0.9.ebuild
new file mode 100644
index 000000000000..3f5657557845
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_pkg_setup
+}