summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/urlwatch/urlwatch-2.0-r2.ebuild')
-rw-r--r--www-misc/urlwatch/urlwatch-2.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-misc/urlwatch/urlwatch-2.0-r2.ebuild b/www-misc/urlwatch/urlwatch-2.0-r2.ebuild
new file mode 100644
index 000000000000..c3a7fa94f154
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ || ( www-client/lynx app-text/html2text )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # https://github.com/thp/urlwatch/issues/34
+ nosetests test || die "tests failed with ${EPYTHON}"
+}