summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/w3mmee')
-rw-r--r--www-client/w3mmee/files/w3mmee-time.patch32
-rw-r--r--www-client/w3mmee/w3mmee-0.3.2_p24-r10.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/www-client/w3mmee/files/w3mmee-time.patch b/www-client/w3mmee/files/w3mmee-time.patch
new file mode 100644
index 000000000000..c63d6542c326
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-time.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/586258
+
+Author: kouyu <ckyoog@gmail.com>
+
+--- a/terms.c
++++ b/terms.c
+@@ -305,11 +305,7 @@
+ struct timeval *tout)
+ {
+ static struct timeval polltv = {
+-#if CLOCKS_PER_SEC > 1
+- 0, 1000000 / CLOCKS_PER_SEC
+-#else
+- 0, 10000
+-#endif
++ 0, CLOCKS_PER_SEC > 1 ? 1000000 / CLOCKS_PER_SEC : 10000
+ };
+ int m;
+ struct timeval tv;
+@@ -779,11 +775,7 @@
+ #endif
+
+ static struct timeval display_delta = {
+-#if CLOCKS_PER_SEC > 1
+- 0, 1000000 / CLOCKS_PER_SEC,
+-#else
+- 0, 10000
+-#endif
++ 0, CLOCKS_PER_SEC > 1 ? 1000000 / CLOCKS_PER_SEC : 10000
+ };
+
+ static int
diff --git a/www-client/w3mmee/w3mmee-0.3.2_p24-r10.ebuild b/www-client/w3mmee/w3mmee-0.3.2_p24-r10.ebuild
index f96eff960147..b08f0b4a3989 100644
--- a/www-client/w3mmee/w3mmee-0.3.2_p24-r10.ebuild
+++ b/www-client/w3mmee/w3mmee-0.3.2_p24-r10.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-gcc-4.4.patch
"${FILESDIR}"/${PN}-gcc-4.5.patch
"${FILESDIR}"/${PN}-glibc-2.14.patch
+ "${FILESDIR}"/${PN}-time.patch
"${FILESDIR}"/${PN}-tinfo.patch
"${FILESDIR}"/${PN}-w3mman-gentoo.patch
)