summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.19-r3.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.31-r7.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.32-r8.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.33-r14.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.34-r14.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.35-r11.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.36-r8.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.37-r10.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.38-r13.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.39-r6.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.39-r7.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.39-r9.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.40.ebuild6
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
14 files changed, 56 insertions, 28 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r3.ebuild b/sys-libs/glibc/glibc-2.19-r3.ebuild
index 1ebbe700f363..c0f528d06063 100644
--- a/sys-libs/glibc/glibc-2.19-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r3.ebuild
@@ -741,8 +741,10 @@ src_prepare() {
}
glibc_do_configure() {
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
# CXX isnt handled by the multilib system, so if we dont unset here
# we accumulate crap across abis
diff --git a/sys-libs/glibc/glibc-2.31-r7.ebuild b/sys-libs/glibc/glibc-2.31-r7.ebuild
index e531ada0b011..872ca6607a3e 100644
--- a/sys-libs/glibc/glibc-2.31-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r7.ebuild
@@ -789,8 +789,10 @@ src_prepare() {
}
glibc_do_configure() {
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
# CXX isnt handled by the multilib system, so if we dont unset here
# we accumulate crap across abis
diff --git a/sys-libs/glibc/glibc-2.32-r8.ebuild b/sys-libs/glibc/glibc-2.32-r8.ebuild
index 65aa84f364aa..c212d3cdad29 100644
--- a/sys-libs/glibc/glibc-2.32-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.32-r8.ebuild
@@ -813,8 +813,10 @@ src_prepare() {
}
glibc_do_configure() {
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
# CXX isnt handled by the multilib system, so if we dont unset here
# we accumulate crap across abis
diff --git a/sys-libs/glibc/glibc-2.33-r14.ebuild b/sys-libs/glibc/glibc-2.33-r14.ebuild
index 9119534902f5..9747f319bb27 100644
--- a/sys-libs/glibc/glibc-2.33-r14.ebuild
+++ b/sys-libs/glibc/glibc-2.33-r14.ebuild
@@ -492,8 +492,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.34-r14.ebuild b/sys-libs/glibc/glibc-2.34-r14.ebuild
index 1affa01b9a4d..08086a0295b4 100644
--- a/sys-libs/glibc/glibc-2.34-r14.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r14.ebuild
@@ -499,8 +499,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.35-r11.ebuild b/sys-libs/glibc/glibc-2.35-r11.ebuild
index 0c63dac54d10..1cabb7910e7b 100644
--- a/sys-libs/glibc/glibc-2.35-r11.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r11.ebuild
@@ -512,8 +512,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.36-r8.ebuild b/sys-libs/glibc/glibc-2.36-r8.ebuild
index b8bf8d174f36..1267125bf98f 100644
--- a/sys-libs/glibc/glibc-2.36-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.36-r8.ebuild
@@ -543,8 +543,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.37-r10.ebuild b/sys-libs/glibc/glibc-2.37-r10.ebuild
index 84368cf8f50f..0cd04e2c8648 100644
--- a/sys-libs/glibc/glibc-2.37-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.37-r10.ebuild
@@ -559,8 +559,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.38-r13.ebuild b/sys-libs/glibc/glibc-2.38-r13.ebuild
index 3ff40e502358..4e9a53c699bf 100644
--- a/sys-libs/glibc/glibc-2.38-r13.ebuild
+++ b/sys-libs/glibc/glibc-2.38-r13.ebuild
@@ -564,8 +564,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.39-r6.ebuild b/sys-libs/glibc/glibc-2.39-r6.ebuild
index e7ae15692d7a..b090b47f8075 100644
--- a/sys-libs/glibc/glibc-2.39-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.39-r6.ebuild
@@ -589,8 +589,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.39-r7.ebuild b/sys-libs/glibc/glibc-2.39-r7.ebuild
index 3e175b82b580..822a623dbddd 100644
--- a/sys-libs/glibc/glibc-2.39-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.39-r7.ebuild
@@ -589,8 +589,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.39-r9.ebuild b/sys-libs/glibc/glibc-2.39-r9.ebuild
index b73cd8b325eb..746401d90985 100644
--- a/sys-libs/glibc/glibc-2.39-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.39-r9.ebuild
@@ -585,8 +585,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-2.40.ebuild b/sys-libs/glibc/glibc-2.40.ebuild
index 1e2debc4ab65..102da1118a39 100644
--- a/sys-libs/glibc/glibc-2.40.ebuild
+++ b/sys-libs/glibc/glibc-2.40.ebuild
@@ -585,8 +585,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a509c476c930..26a50c00fd1e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -585,8 +585,10 @@ setup_env() {
return 0
fi
- # Glibc does not work with gold (for various reasons) #269274.
- tc-ld-disable-gold
+ # glibc does not work with non-bfd (for various reasons):
+ # * gold (bug #269274)
+ # * mold (bug #860900)
+ tc-ld-force-bfd
if use doc ; then
export MAKEINFO=makeinfo