summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild2
-rw-r--r--sys-fs/f2fs-tools/files/f2fs-tools-1.10.0-fibmap-include-config_h.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
index 94561df90d65..6d2be3599a8d 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
@@ -17,6 +17,8 @@ RDEPEND="
selinux? ( sys-libs/libselinux )"
DEPEND="$RDEPEND"
+PATCHES=( "${FILESDIR}"/${P}-fibmap-include-config_h.patch )
+
src_configure() {
#This is required to install to /sbin, bug #481110
econf \
diff --git a/sys-fs/f2fs-tools/files/f2fs-tools-1.10.0-fibmap-include-config_h.patch b/sys-fs/f2fs-tools/files/f2fs-tools-1.10.0-fibmap-include-config_h.patch
new file mode 100644
index 000000000000..df57412b74cf
--- /dev/null
+++ b/sys-fs/f2fs-tools/files/f2fs-tools-1.10.0-fibmap-include-config_h.patch
@@ -0,0 +1,15 @@
+See https://bugs.gentoo.org/649168
+
+Patch by: Matt Whitlock <gentoo@mattwhitlock.name>
+
+diff -Naur a/tools/fibmap.c b/tools/fibmap.c
+--- a/tools/fibmap.c 2018-03-01 00:09:24.861919778 +0000
++++ b/tools/fibmap.c 2018-03-01 17:31:48.854604556 +0000
+@@ -15,6 +15,7 @@
+ #ifndef O_LARGEFILE
+ #define O_LARGEFILE 0
+ #endif
++#include "config.h"
+ #include <unistd.h>
+ #include <string.h>
+ #include <stdlib.h>