summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest1
-rw-r--r--sys-apps/bleachbit/bleachbit-3.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index e12f04e9bab6..fff9dd54226c 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,2 +1 @@
-DIST bleachbit-3.0.tar.bz2 562646 BLAKE2B 4acdd5469ac1b36ff149231ad0b1b2e4e85a54a81c24c7751ceeed569526b905c1cc6be5201c4fb6929eb48e0553f0b27016de2584ee2f702492cc3fe659c2f9 SHA512 0d61f0b183c0d453275913741020c54c2915be9df45be706203e2278b125f4a02c75865117a7a2d587a034caa9bf109b2f498a4d522cc103c3879cc4a5d4854d
DIST bleachbit-4.0.0.tar.bz2 599756 BLAKE2B 05a4dbf9e0b6bbcba528875a82e36eb9f91ae84c5bdc6f8f69063a54bd192332f5dd1d22ee5a737243eb5fb74cf0362eace1b50a73f7c1d0557a8cba146dea01 SHA512 ce120239b411c6e177af0e22a16b583ac3ae8903ba13579878942492e4e221355da28f737d6c78811312bfcc888af7c8dba6c153673f4e1542cc2aceedf2d2c9
diff --git a/sys-apps/bleachbit/bleachbit-3.0.ebuild b/sys-apps/bleachbit/bleachbit-3.0.ebuild
deleted file mode 100644
index 6129e74e6df4..000000000000
--- a/sys-apps/bleachbit/bleachbit-3.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit desktop distutils-r1
-
-DESCRIPTION="Clean junk to free disk space and to maintain privacy"
-HOMEPAGE="https://www.bleachbit.org"
-SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- dev-python/chardet[$PYTHON_USEDEP]
- dev-python/pygobject:3[$PYTHON_USEDEP]
- dev-python/scandir[$PYTHON_USEDEP]
-"
-BDEPEND="
- dev-python/setuptools[$PYTHON_USEDEP]
- sys-devel/gettext
-"
-
-python_prepare_all() {
- # choose correct Python implementation, bug #465254
- sed -i 's/python/${EPYTHON}/g' po/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C po local
-}
-
-python_install() {
- distutils-r1_python_install
- python_newscript ${PN}.py ${PN}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- emake -C po DESTDIR="${D}" install
-
- # https://bugs.gentoo.org/388999
- insinto /usr/share/bleachbit/cleaners
- doins cleaners/*.xml
-
- insinto /usr/share/bleachbit
- doins data/app-menu.ui
-
- doicon ${PN}.png
- domenu ${PN}.desktop
-}