summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libmems')
-rw-r--r--sci-libs/libmems/Manifest2
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-boost.patch120
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-build.patch19
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch71
-rw-r--r--sci-libs/libmems/libmems-1.6.ebuild32
-rw-r--r--sci-libs/libmems/libmems-1.6_p1.ebuild32
-rw-r--r--sci-libs/libmems/libmems-9999.ebuild30
-rw-r--r--sci-libs/libmems/metadata.xml5
8 files changed, 311 insertions, 0 deletions
diff --git a/sci-libs/libmems/Manifest b/sci-libs/libmems/Manifest
new file mode 100644
index 000000000000..c1c88d19ccc9
--- /dev/null
+++ b/sci-libs/libmems/Manifest
@@ -0,0 +1,2 @@
+DIST libmems-1.6.tar.bz2 441051 SHA256 624ef4921f00c2c81d179819a5d1af91f01b1ec66dfa5f7c977b8e42696e76b4 SHA512 4a4fdc2849c5e292175249834e702421c975b6fc5995c50abce90ad2e18df3a4fd0192330a0200dc18aa26bcce4de15baccd6f269555a7710dd4e620c0ca0738 WHIRLPOOL 4ea1cf8feca0a165dc970dc93e36a8602eb746ccb31bedfc20f960c9bb0c8268152f39b5725c6c917a2869df93d0539b518db4db4b43815172218f6620913cfe
+DIST libmems-1.6_p1.tar.xz 226628 SHA256 c692d7d42378e7264d0a39674d1a6072183ee4c073ad90858153986b6a8b4848 SHA512 c6336f69b767bba010617deb2de9bb8fbbbaf516de3b1d293b062c76c6a763166080badd730938c6d849602d64a968edb6d4622b5d3e7ea7a6d8bc38164d3d73 WHIRLPOOL bc216dfb0c24c13b7b770da00100730e0e9b350c7bb6b312a480a83b51bc8c212e6ed73f08a88a7d262da8d4ed9a4c788883cbcfa3f2b2cdc362888e85b7f66a
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-boost.patch b/sci-libs/libmems/files/libmems-1.6_p1-boost.patch
new file mode 100644
index 000000000000..4f0c775a6d9c
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-boost.patch
@@ -0,0 +1,120 @@
+ libMems/Backbone.cpp | 2 +-
+ libMems/Files.h | 64 +++++++++++++++++++++---------------------
+ libMems/ProgressiveAligner.cpp | 2 +-
+ 3 files changed, 34 insertions(+), 34 deletions(-)
+
+diff --git a/libMems/Backbone.cpp b/libMems/Backbone.cpp
+index 86698a9..0025cd8 100644
+--- a/libMems/Backbone.cpp
++++ b/libMems/Backbone.cpp
+@@ -15,7 +15,7 @@
+ #include "libMems/Islands.h"
+ #include "libMems/CompactGappedAlignment.h"
+
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/graph/graph_traits.hpp>
+ #include <boost/graph/adjacency_list.hpp>
+ #include <boost/graph/topological_sort.hpp>
+diff --git a/libMems/Files.h b/libMems/Files.h
+index 8d6e9be..8191065 100644
+--- a/libMems/Files.h
++++ b/libMems/Files.h
+@@ -22,44 +22,44 @@
+
+ #include "boost/filesystem/operations.hpp"
+ #include "boost/filesystem/exception.hpp"
+-#include "boost/algorithm/string.hpp"
++#include "boost/algorithm/string.hpp"
+ #include <string>
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
+
+
+-/**
+- * Register a file name to be deleted before the process exits
+- * When passed an empty string, it does not add to the list of files to delete
+- * @param fname The name of a file to delete, empty strings are ignored
+- * @return A vector of file names registered for deletion
+- */
+-std::vector< std::string >& registerFileToDelete( std::string fname = "" );
+-
+-inline
+-std::vector< std::string >& registerFileToDelete( std::string fname ) {
+- // since this vector is needed when atexit() is called we allocate it
+- // on the heap so its destructor won't get called
+- static std::vector< std::string >* files = new std::vector< std::string >();
+-#pragma omp critical
+-{
+- if( fname != "" )
+- files->push_back( fname );
+-}
+- return *files;
+-}
++/**
++ * Register a file name to be deleted before the process exits
++ * When passed an empty string, it does not add to the list of files to delete
++ * @param fname The name of a file to delete, empty strings are ignored
++ * @return A vector of file names registered for deletion
++ */
++std::vector< std::string >& registerFileToDelete( std::string fname = "" );
+
+-void deleteRegisteredFiles();
+-inline
+-void deleteRegisteredFiles() {
+- // don't be a slob, clean up after yourself:
+- // delete any files that are laying around
+- std::vector< std::string >& del_files = registerFileToDelete();
+- for( int fileI = 0; fileI < del_files.size(); fileI++ )
+- boost::filesystem::remove( del_files[ fileI ] );
+- del_files.clear(); // clear the deleted files from the list
+-}
++inline
++std::vector< std::string >& registerFileToDelete( std::string fname ) {
++ // since this vector is needed when atexit() is called we allocate it
++ // on the heap so its destructor won't get called
++ static std::vector< std::string >* files = new std::vector< std::string >();
++#pragma omp critical
++{
++ if( fname != "" )
++ files->push_back( fname );
++}
++ return *files;
++}
++
++void deleteRegisteredFiles();
++inline
++void deleteRegisteredFiles() {
++ // don't be a slob, clean up after yourself:
++ // delete any files that are laying around
++ std::vector< std::string >& del_files = registerFileToDelete();
++ for( int fileI = 0; fileI < del_files.size(); fileI++ )
++ boost::filesystem::remove( del_files[ fileI ] );
++ del_files.clear(); // clear the deleted files from the list
++}
+
+
+ /**
+@@ -80,7 +80,7 @@ std::string CreateTempFileName(const std::string& prefix)
+ #endif
+ boost::filesystem::path path( prefix );
+ dir = path.branch_path().string();
+- name = path.leaf();
++ name = path.filename().string();
+ if( name == "/" )
+ {
+ dir += name;
+diff --git a/libMems/ProgressiveAligner.cpp b/libMems/ProgressiveAligner.cpp
+index 3be5fe0..5667a9e 100644
+--- a/libMems/ProgressiveAligner.cpp
++++ b/libMems/ProgressiveAligner.cpp
+@@ -27,7 +27,7 @@
+
+ #include <boost/dynamic_bitset.hpp>
+ #include <boost/tuple/tuple.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/graph/graph_traits.hpp>
+ #include <boost/graph/adjacency_list.hpp>
+ #include <boost/graph/johnson_all_pairs_shortest.hpp>
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-build.patch b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
new file mode 100644
index 000000000000..63e5f1216756
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
@@ -0,0 +1,19 @@
+ libMems/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libMems/Makefile.am b/libMems/Makefile.am
+index 6101f71..d66053d 100644
+--- a/libMems/Makefile.am
++++ b/libMems/Makefile.am
+@@ -2,10 +2,10 @@
+ if DEBUG
+ D_CXXFLAGS = -Wall -g -D__GNDEBUG__
+ endif
+-OPTIMIZATION = -O2 -Wall -funroll-loops -fomit-frame-pointer -ftree-vectorize
+ AM_CFLAGS = $(OPTIMIZATION) @DEPS_CFLAGS@ -DUSE_POSIX_AIO @OPENMP_CFLAGS@
+ AM_CXXFLAGS = $(OPTIMIZATION) @DEPS_CFLAGS@ @BOOST_CPPFLAGS@ $(D_CXXFLAGS) @EXTRA_CXX_FLAGS@ @OPENMP_CXXFLAGS@
+ AM_LDFLAGS = $(OPTIMIZATION)
++AM_CPPFLAGS=-I$(top_srcdir)
+
+ LIBMEMS_H = \
+ RepeatHash.h MatchHashEntry.h \
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch b/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch
new file mode 100644
index 000000000000..ec620ebb35aa
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch
@@ -0,0 +1,71 @@
+ libMems/CompactGappedAlignment.h | 36 ++++++++++++++++++------------------
+ 1 file changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/libMems/CompactGappedAlignment.h b/libMems/CompactGappedAlignment.h
+index bf78477..942d4aa 100644
+--- a/libMems/CompactGappedAlignment.h
++++ b/libMems/CompactGappedAlignment.h
+@@ -13,7 +13,7 @@
+ #include "config.h"
+ #endif
+
+-#include "libGenome/gnDebug.h"
++#include "libGenome/gnDebug.h"
+ #include "libGenome/gnFilter.h"
+ #include "libGenome/gnSequence.h"
+ #include "libMems/SparseAbstractMatch.h"
+@@ -103,15 +103,15 @@ public:
+ /** Eliminates any columns that contain only gap characters */
+ void CondenseGapColumns();
+
+- void swap( CompactGappedAlignment& other ){ swap(&other); }
+-
+-protected:
+- // for use by derived classes in order to swap contents
+- void swap( CompactGappedAlignment* other ){
+- std::swap( align_matrix, other->align_matrix );
+- std::swap( bcount, other->bcount );
+- BaseType::swap( other );
+- }
++ void swap( CompactGappedAlignment& other ){ swap(&other); }
++
++protected:
++ // for use by derived classes in order to swap contents
++ void swap( CompactGappedAlignment* other ){
++ std::swap( align_matrix, other->align_matrix );
++ std::swap( bcount, other->bcount );
++ BaseType::swap( other );
++ }
+
+ std::vector< bitset_t > align_matrix; /**< aligned positions have true values, gaps are false */
+ std::vector< std::vector< size_t > > bcount;
+@@ -572,7 +572,7 @@ void CompactGappedAlignment<BaseType>::CropEnd(gnSeqI crop_amount){
+ this->SetStart(i, 0);
+ }
+ }
+- SetAlignmentLength( this->AlignmentLength() - crop_amount );
++ this->SetAlignmentLength( this->AlignmentLength() - crop_amount );
+ this->create_bitcount();
+ if( !this->validate() )
+ std::cerr << "CropEnd error\n";
+@@ -806,13 +806,13 @@ void CompactGappedAlignment<BaseType>::CondenseGapColumns()
+
+ }
+
+-namespace std {
+-template<> inline
+-void swap( mems::CompactGappedAlignment<>& a, mems::CompactGappedAlignment<>& b )
+-{
+- a.swap(b);
+-}
+-}
++namespace std {
++template<> inline
++void swap( mems::CompactGappedAlignment<>& a, mems::CompactGappedAlignment<>& b )
++{
++ a.swap(b);
++}
++}
+
+
+ #endif // __CompactGappedAlignment_h__
diff --git a/sci-libs/libmems/libmems-1.6.ebuild b/sci-libs/libmems/libmems-1.6.ebuild
new file mode 100644
index 000000000000..56bb4be6dd7f
--- /dev/null
+++ b/sci-libs/libmems/libmems-1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-libs/boost
+ sci-libs/libgenome
+ sci-libs/libmuscle"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/sci-libs/libmems/libmems-1.6_p1.ebuild b/sci-libs/libmems/libmems-1.6_p1.ebuild
new file mode 100644
index 000000000000..c8d7dc9ecc92
--- /dev/null
+++ b/sci-libs/libmems/libmems-1.6_p1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-libs/boost
+ sci-libs/libgenome
+ sci-libs/libmuscle"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-boost.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ )
diff --git a/sci-libs/libmems/libmems-9999.ebuild b/sci-libs/libmems/libmems-9999.ebuild
new file mode 100644
index 000000000000..ff9052c10cfb
--- /dev/null
+++ b/sci-libs/libmems/libmems-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+ESVN_REPO_URI="https://mauve.svn.sourceforge.net/svnroot/mauve/libMems/trunk"
+
+inherit autotools-utils subversion
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI=""
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc"
+KEYWORDS=""
+
+CDEPEND="
+ dev-libs/boost
+ sci-libs/libgenome
+ sci-libs/libmuscle"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}"
diff --git a/sci-libs/libmems/metadata.xml b/sci-libs/libmems/metadata.xml
new file mode 100644
index 000000000000..d4648212cbad
--- /dev/null
+++ b/sci-libs/libmems/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>