summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/colamd/files/colamd-2.7.4-autotools.patch')
-rw-r--r--sci-libs/colamd/files/colamd-2.7.4-autotools.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/colamd/files/colamd-2.7.4-autotools.patch b/sci-libs/colamd/files/colamd-2.7.4-autotools.patch
new file mode 100644
index 000000000000..f58464cd987f
--- /dev/null
+++ b/sci-libs/colamd/files/colamd-2.7.4-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Source Demo
++include_HEADERS = $(top_srcdir)/Include/colamd.h
++EXTRA_DIST = README.txt
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(colamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADER( UFconfig.h )
++AC_OUTPUT(
++ Makefile \
++ Demo/Makefile \
++ Source/Makefile)
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,11 @@
++AM_CFLAGS = -I$(top_srcdir)/Include
++lib_LTLIBRARIES = libcolamd.la
++noinst_LTLIBRARIES = libcolamdi.la libcolamdl.la
++
++libcolamdl_la_SOURCES = colamd.c
++libcolamdl_la_CPPFLAGS = -DDLONG
++
++libcolamdi_la_SOURCES = colamd.c
++
++libcolamd_la_SOURCES = colamd_global.c
++libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,20 @@
++LDADD = $(top_builddir)/Source/libcolamd.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = colamd_example colamd_l_example
++colamd_example_SOURCES = colamd_example.c
++colamd_l_example_SOURCES = colamd_l_example.c
++colamd_l_example_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Testing $$i failed"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out