summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/pysam/Manifest1
-rw-r--r--sci-biology/pysam/files/pysam-0.21.0-cython-3.patch24
-rw-r--r--sci-biology/pysam/pysam-0.21.0.ebuild72
3 files changed, 0 insertions, 97 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index fae7b9793388..2859d25293fc 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,2 +1 @@
-DIST pysam-0.21.0.gh.tar.gz 3842829 BLAKE2B 83db290ec0bae71106276ed4f1721292c0d2fa55053c7451f0a8a79619b1c4d8444b99293ac5d8051bfb0b59e984e32a89798bab091e3a019b7c2a3fb7414d1c SHA512 b2ac986b6a352df1d2066a224d710648a88d8ad44273623a89ae0f4bb2645b00f0d0e1685c8ccedfd379259255957e653f3c3199621ac1d4c26098f538b6bfa7
DIST pysam-0.22.1.gh.tar.gz 3885851 BLAKE2B 6f83c445c7e63e28823f443b0f106726303b0609f4040e9dca930c820d48c2adfe13d33ecffb514ce75c3b03968af050652689a0be39aaabca1af546e9188480 SHA512 fb8dc7c4a6ae908d8d409789f2706cce589d4b6a1057bcc4043f8a26a5b390f79d30d1a1cbe69cbf370caabf261ed8367685393240765080e94f1782ed7f0350
diff --git a/sci-biology/pysam/files/pysam-0.21.0-cython-3.patch b/sci-biology/pysam/files/pysam-0.21.0-cython-3.patch
deleted file mode 100644
index 303a4fb0dcdc..000000000000
--- a/sci-biology/pysam/files/pysam-0.21.0-cython-3.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 17bb13dcfdb56ac238458dcef23fe01893a892e9 Mon Sep 17 00:00:00 2001
-From: John Marshall <jmarshall@hey.com>
-Date: Sat, 8 Apr 2023 11:00:46 +1200
-Subject: [PATCH] Remove incorrect type annotation
-
-The annotation already in pysam/libcbcf.pyi is correct.
-Fixes #1179 as reopened on April 6th.
----
- pysam/libcbcf.pyx | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pysam/libcbcf.pyx b/pysam/libcbcf.pyx
-index 8c088af2..8ecfe5f3 100644
---- a/pysam/libcbcf.pyx
-+++ b/pysam/libcbcf.pyx
-@@ -3479,7 +3479,7 @@ cdef class VariantRecordSample(object):
- return bcf_format_get_alleles(self)
-
- @alleles.setter
-- def alleles(self, value: tuple):
-+ def alleles(self, value):
- # Sets the genotype, supply a tuple of alleles to set.
- # The supplied alleles need to be defined in the correspoding pysam.libcbcf.VariantRecord
- # The genotype is reset when an empty tuple, None or (None,) is supplied
diff --git a/sci-biology/pysam/pysam-0.21.0.ebuild b/sci-biology/pysam/pysam-0.21.0.ebuild
deleted file mode 100644
index 77292ed29613..000000000000
--- a/sci-biology/pysam/pysam-0.21.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
-HOMEPAGE="
- https://github.com/pysam-developers/pysam
- https://pypi.org/project/pysam/"
-SRC_URI="https://github.com/pysam-developers/pysam/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="=sci-libs/htslib-1.17*:="
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- =sci-biology/bcftools-1.17*
- =sci-biology/samtools-1.17*
- )"
-
-distutils_enable_tests pytest
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- # backport
- # https://github.com/pysam-developers/pysam/commit/17bb13dcfdb56ac238458dcef23fe01893a892e9
- "${FILESDIR}"/${P}-cython-3.patch
-)
-
-EPYTEST_DESELECT=(
- # only work with bundled htslib
- 'tests/tabix_test.py::TestRemoteFileHTTP'
- 'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
-)
-
-python_prepare_all() {
- # unbundle htslib
- export HTSLIB_MODE="external"
- export HTSLIB_INCLUDE_DIR="${ESYSROOT}"/usr/include
- export HTSLIB_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
- rm -r htslib || die
-
- # prevent setup.py from adding RPATHs (except $ORIGIN)
- sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
- -i setup.py || die
-
- if use test; then
- einfo "Building test data"
- emake -C tests/pysam_data
- emake -C tests/cbcf_data
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- # breaks with parallel build
- # need to avoid dropping .so plugins into
- # build-lib, which breaks tests
- esetup.py build_ext --inplace -j1
- distutils-r1_python_compile -j1
-}