summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.1.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index fa6ba8bc1a50..c1827ae2fea1 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,2 +1 @@
-DIST gnome-bluetooth-3.20.1.tar.xz 615880 BLAKE2B 4b578bc7d1bf1d700f57117202e5f6461e1ace972f6922425a012eb1bcf96c7e511222a1dbd344469e0db96142d4da99face54e07d7359e28e20234d7766a70c SHA512 945dde99c6531e369702dea22e60f5b05759d751b16b091fc67c256e949cee8153f60ac7ad616c086366a0141b263b068fad28bab4b50b84356d59b4e464d88a
DIST gnome-bluetooth-3.28.2.tar.xz 349456 BLAKE2B 24a8adbbd37a6a7338a10bb84fd113c3a65bb9c5ef277c9df082f10f52b9d9dc2bc3ff6182993fd85fb5f5f8269a965f0aba864f73ed8595a700a51e59242fc1 SHA512 03f66f8c5c195b10cf2c13dc93191b9f2f79adae099ddb8037ef1277731f37b8f0a42b603e8aacbe2fb108be6abf7a77a823d86d5fac62a42a53e3498d53d87e
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.1.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.1.ebuild
deleted file mode 100644
index 6777d42e513e..000000000000
--- a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2 udev user
-
-DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
-
-LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
-SLOT="2/13" # subslot = libgnome-bluetooth soname version
-IUSE="debug +introspection"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.38:2
- media-libs/libcanberra[gtk3]
- >=x11-libs/gtk+-3.12:3[introspection?]
- x11-libs/libnotify
- virtual/udev
- introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
-"
-RDEPEND="${COMMON_DEPEND}
- >=net-wireless/bluez-5
-"
-DEPEND="${COMMON_DEPEND}
- !net-wireless/bluez-gnome
- app-text/docbook-xml-dtd:4.1.2
- dev-libs/libxml2:2
- dev-util/gdbus-codegen
- dev-util/glib-utils
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.40.0
- virtual/libudev
- virtual/pkgconfig
- x11-base/xorg-proto
-"
-# eautoreconf needs:
-# gnome-base/gnome-common
-
-pkg_setup() {
- enewgroup plugdev
-}
-
-src_prepare() {
- # Regenerate gdbus-codegen files to allow using any glib version; bug #436236
- # https://bugzilla.gnome.org/show_bug.cgi?id=758096
- rm -v lib/bluetooth-client-glue.{c,h} || die
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- $(usex debug --enable-debug=yes ' ') \
- $(use_enable introspection) \
- --enable-documentation \
- --disable-desktop-update \
- --disable-icon-update \
- --disable-static
-}
-
-src_install() {
- gnome2_src_install
- udev_dorules "${FILESDIR}"/61-${PN}.rules
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
- elog "Don't forget to add yourself to the plugdev group "
- elog "if you want to be able to control bluetooth transmitter."
- fi
-}