summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/retroshare/files/retroshare-0.6.7-fix-miniupnp-api-v18.patch32
-rw-r--r--net-p2p/retroshare/retroshare-0.6.7-r2.ebuild129
2 files changed, 161 insertions, 0 deletions
diff --git a/net-p2p/retroshare/files/retroshare-0.6.7-fix-miniupnp-api-v18.patch b/net-p2p/retroshare/files/retroshare-0.6.7-fix-miniupnp-api-v18.patch
new file mode 100644
index 000000000000..37d38b11c548
--- /dev/null
+++ b/net-p2p/retroshare/files/retroshare-0.6.7-fix-miniupnp-api-v18.patch
@@ -0,0 +1,32 @@
+From f1b89c4f87d77714571b4135c301bf0429096a20 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C8=98tefan=20Talpalaru?= <stefantalpalaru@yahoo.com>
+Date: Wed, 12 Jun 2024 01:00:41 +0200
+Subject: [PATCH] Support the miniupnpc-2.2.8 API change
+# NOTE: Taken from the official libretroshare repo
+# https://github.com/RetroShare/libretroshare/commit/c54e0266e4483797c1d6bacee6f563979d683464
+index 7178a8e39..5e5358fb9 100644
+--- a/libretroshare/src/rs_upnp/upnphandler_miniupnp.cc
++++ b/libretroshare/src/rs_upnp/upnphandler_miniupnp.cc
+@@ -41,6 +41,9 @@ class uPnPConfigData
+ struct UPNPUrls urls;
+ struct IGDdatas data;
+ char lanaddr[16]; /* my ip address on the LAN */
++#if MINIUPNPC_API_VERSION >= 18
++ char wanaddr[16]; /* my ip address on the WAN */
++#endif
+ };
+
+ #include <iostream>
+@@ -139,6 +142,10 @@ bool upnphandler::initUPnPState()
+ putchar('\n');
+ if(UPNP_GetValidIGD(upcd->devlist, &(upcd->urls),
+ &(upcd->data), upcd->lanaddr,
+- sizeof(upcd->lanaddr)))
++ sizeof(upcd->lanaddr)
++#if MINIUPNPC_API_VERSION >= 18
++ , upcd->wanaddr, sizeof(upcd->wanaddr)
++#endif
++ ))
+ {
+ printf("Found valid IGD : %s\n",
+ upcd->urls.controlURL); \ No newline at end of file
diff --git a/net-p2p/retroshare/retroshare-0.6.7-r2.ebuild b/net-p2p/retroshare/retroshare-0.6.7-r2.ebuild
new file mode 100644
index 000000000000..49e285a13636
--- /dev/null
+++ b/net-p2p/retroshare/retroshare-0.6.7-r2.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic desktop qmake-utils xdg
+
+DESCRIPTION="Friend to Friend secure communication and sharing application"
+HOMEPAGE="https://retroshare.cc"
+SRC_URI="https://download.opensuse.org/repositories/network:/retroshare/Debian_Testing/retroshare-common_${PV}.orig.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/RetroShare"
+# NOTE: GitHub releases/archive is impractical to build so we use the OBS repo
+# but they squash point releases which is bad for us
+
+LICENSE="AGPL-3 Apache-2.0 CC-BY-SA-4.0 GPL-2 GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli +gui +jsonapi keyring libupnp +miniupnp +service +sqlcipher plugins"
+
+REQUIRED_USE="
+ || ( gui service )
+ ?? ( libupnp miniupnp )
+ plugins? ( gui )
+ service? ( || ( cli jsonapi ) )
+"
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ keyring? ( app-crypt/libsecret )
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtxml:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ libupnp? ( net-libs/libupnp:= )
+ miniupnp? ( net-libs/miniupnpc:= )
+ sqlcipher? ( dev-db/sqlcipher )
+ !sqlcipher? ( dev-db/sqlite:3 )
+ plugins? (
+ media-libs/speex
+ media-libs/speexdsp
+ <media-video/ffmpeg-5
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ jsonapi? ( >=dev-libs/rapidjson-1.1.0 )
+ gui? ( dev-qt/designer:5 )
+"
+BDEPEND="
+ dev-build/cmake
+ dev-qt/qtcore:5
+ virtual/pkgconfig
+ gui? ( x11-base/xorg-proto )
+ jsonapi? ( app-text/doxygen )
+"
+PATCHES=( "${FILESDIR}/${P}-fix-miniupnp-api-v18.patch" )
+
+src_configure() {
+ local qconfigs=(
+ $(usex cli '' 'no_')rs_service_terminal_login
+ $(usex keyring '' 'no_')rs_autologin
+ $(usex gui '' 'no_')retroshare_gui
+ $(usex jsonapi '' 'no_')rs_jsonapi
+ $(usex service '' 'no_')retroshare_service
+ $(usex sqlcipher '' 'no_')sqlcipher
+ $(usex plugins '' 'no_')retroshare_plugins
+ )
+
+ local qupnplibs="none"
+ use miniupnp && qupnplibs="miniupnpc"
+ use libupnp && qupnplibs="upnp ixml"
+
+ # bug 907898
+ use elibc_musl && append-flags -D_LARGEFILE64_SOURCE
+
+ # REVIEW: qmake is deprecated
+ # https://github.com/RetroShare/RetroShare/tree/master/jsonapi-generator
+ eqmake5 CONFIG+="${qconfigs[*]}" \
+ RS_MAJOR_VERSION=$(ver_cut 1) \
+ RS_MINOR_VERSION=$(ver_cut 2) \
+ RS_MINI_VERSION=$(ver_cut 3) \
+ RS_EXTRA_VERSION="-gentoo-${PR}" \
+ RS_UPNP_LIB="${qupnplibs}"
+}
+
+src_install() {
+ use gui && dobin retroshare-gui/src/retroshare
+ use service && dobin retroshare-service/src/retroshare-service
+
+ insinto /usr/share/retroshare
+ doins libbitdht/src/bitdht/bdboot.txt
+ use gui && doins -r retroshare-gui/src/qss
+
+ dodoc README.asciidoc
+
+ if use gui; then
+ make_desktop_entry retroshare
+
+ for i in 24 48 64 128 ; do
+ doicon -s ${i} "data/${i}x${i}/apps/retroshare.png"
+ done
+ fi
+ if use plugins; then
+ insinto /usr/lib/retroshare/extensions6
+ doins plugins/*/lib/*.so
+ fi
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ if ! use sqlcipher && ! has_version "net-p2p/retroshare[-sqlcipher]"; then
+ ewarn "You have disabled GXS database encryption, ${PN} will use SQLite"
+ ewarn "instead of SQLCipher for GXS databases."
+ ewarn "Builds using SQLite and builds using SQLCipher have incompatible"
+ ewarn "database format, so you will need to manually delete GXS"
+ ewarn "database (loosing all your GXS data and identities) when you"
+ ewarn "toggle sqlcipher USE flag."
+ fi
+}