summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/eps')
-rw-r--r--net-mail/eps/Manifest1
-rw-r--r--net-mail/eps/eps-1.7.ebuild38
-rw-r--r--net-mail/eps/metadata.xml6
3 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/eps/Manifest b/net-mail/eps/Manifest
new file mode 100644
index 000000000000..62d5e5f219b9
--- /dev/null
+++ b/net-mail/eps/Manifest
@@ -0,0 +1 @@
+DIST eps-1.7.tar.gz 29913 RMD160 d6723263ff485a0c5e10108ed697a71207fc626a SHA1 94af7a7ddc7f02c1f521ec33e4504be604dcf969 SHA256 8eb7ebb0331a8a604d4f3d029b9ec90debef40be4a4b71a7364cfec4c4175bd5
diff --git a/net-mail/eps/eps-1.7.ebuild b/net-mail/eps/eps-1.7.ebuild
new file mode 100644
index 000000000000..1ead55368c06
--- /dev/null
+++ b/net-mail/eps/eps-1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Inter7 Email Processing and mht System library"
+HOMEPAGE="http://www.inter7.com/eps"
+SRC_URI="http://www.inter7.com/eps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e 's:/usr:$(DESTDIR)$(prefix):g' \
+ -e 's:\(DEFS.*\):\1 $(CFLAGS):' \
+ -e 's:$(DEFS):$(DEFS) -fPIC:' \
+ -e 's:-shared:-shared -Wl,-soname,libeps.so $(LDFLAGS):' \
+ -e 's:cp -pf:cp -f:g' \
+ Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" || die "emake failed"
+}
+
+src_install() {
+ emake prefix=/usr DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install \
+ || die "emake install failed"
+ dodoc ChangeLog TODO doc/*
+}
diff --git a/net-mail/eps/metadata.xml b/net-mail/eps/metadata.xml
new file mode 100644
index 000000000000..c0f9eb6c90f2
--- /dev/null
+++ b/net-mail/eps/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription>EPS (Email Parsing System) is intended to give people the ability to write their own email processing tools. Whether you want to process incoming and outgoing emails, or just analyze a message, this package is intended to aid in that endeavor.</longdescription>
+</pkgmetadata>