summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch')
-rw-r--r--net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch b/net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch
new file mode 100644
index 000000000000..54e9f54f8dc1
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch
@@ -0,0 +1,27 @@
+--- a/configure.in
++++ b/configure.in
+@@ -431,7 +431,23 @@
+ [[#include <linux/if_packet.h>]])
+
+ # If we use DPDK we might be able to use libnuma
+-AC_CHECK_LIB(numa, numa_node_to_cpus, have_numa=1, have_numa=0)
++AC_ARG_WITH(numa,
++ AS_HELP_STRING(--with-numa,include NUMA support),
++[
++ if test "$withval" = no
++ then
++ want_numa=no
++ else
++ want_numa=yes
++ fi
++],[
++ # Default to building without NUMA
++ want_numa=yes
++])
++
++if test "$want_numa" != no; then
++ AC_CHECK_LIB(numa, numa_node_to_cpus, have_numa=1, have_numa=0)
++fi
+
+ # Checks for various "optional" libraries
+ AC_CHECK_LIB(pthread, pthread_create, have_pthread=1, have_pthread=0)