summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnet/libnet-1.2_rc4.ebuild')
-rw-r--r--net-libs/libnet/libnet-1.2_rc4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libnet/libnet-1.2_rc4.ebuild b/net-libs/libnet/libnet-1.2_rc4.ebuild
new file mode 100644
index 000000000000..e4c9ab48021b
--- /dev/null
+++ b/net-libs/libnet/libnet-1.2_rc4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="library providing an API for commonly used low-level network functions"
+HOMEPAGE="http://libnet-dev.sourceforge.net/ https://github.com/libnet/libnet"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.gz"
+
+LICENSE="BSD BSD-2 HPND"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+DOCS=(
+ ChangeLog.md README.md doc/{MIGRATION,RAWSOCKET_NON_SEQUITUR,TODO}
+)
+S=${WORKDIR}/${P/_/-}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}