summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libbt/files/libbt-1.06-build.patch')
-rw-r--r--net-libs/libbt/files/libbt-1.06-build.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/libbt/files/libbt-1.06-build.patch b/net-libs/libbt/files/libbt-1.06-build.patch
new file mode 100644
index 000000000000..de778a75f165
--- /dev/null
+++ b/net-libs/libbt/files/libbt-1.06-build.patch
@@ -0,0 +1,53 @@
+http://bugs.gentoo.org/152489
+http://bugs.gentoo.org/248034
+http://bugs.gentoo.org/315213
+
+--- src/btlist.c
++++ src/btlist.c
+@@ -13,6 +13,7 @@
+
+ #include "config.h"
+
++#include <sys/types.h>
+ #include <openssl/sha.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- src/peer.c
++++ src/peer.c
+@@ -35,6 +35,7 @@
+ #include <time.h>
+ #include <poll.h>
+ #include <assert.h>
++#include <limits.h>
+
+ #include "bterror.h"
+ #include "btmessage.h"
+--- src/udpproto.c 2009-12-07 15:03:54.000000000 +0100
++++ src/udpproto.c 2009-12-07 15:04:10.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <limits.h>
+
+ #include <arpa/inet.h>
+
+--- src/Makefile.in 2009-12-07 15:57:24.000000000 +0100
++++ src/Makefile.in 2009-12-07 15:57:34.000000000 +0100
+@@ -30,7 +30,7 @@
+ CPPFLAGS:=@CPPFLAGS@
+ CFLAGS+=-g -Wall -I../include -I$(top_srcdir)/include
+
+-LIBS:=@LIBS@ `curl-config --libs` -lm
++LIBS:=@LIBS@ `curl-config --libs` -lm -lcrypto
+ LDFLAGS:=-g -L. @LDFLAGS@
+ VERSION=1.06
+ MAKEDEPEND=@MAKEDEPEND@
+--- Makefile.in 2009-12-07 17:36:18.000000000 +0100
++++ Makefile.in 2009-12-07 17:36:28.000000000 +0100
+@@ -1,4 +1,4 @@
+-all: depend compile
++all: compile
+
+ compile:
+ cd src && ${MAKE}