summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libfame')
-rw-r--r--media-libs/libfame/libfame-0.9.1-r4.ebuild (renamed from media-libs/libfame/libfame-0.9.1-r3.ebuild)17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-libs/libfame/libfame-0.9.1-r3.ebuild b/media-libs/libfame/libfame-0.9.1-r4.ebuild
index d8afa4ffd3a4..69b4bfe45f41 100644
--- a/media-libs/libfame/libfame-0.9.1-r3.ebuild
+++ b/media-libs/libfame/libfame-0.9.1-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
DESCRIPTION="MPEG-1 and MPEG-4 video encoding library"
HOMEPAGE="http://fame.sourceforge.net/"
@@ -33,15 +33,16 @@ src_prepare() {
eautoreconf
}
-multilib_src_configure() {
+src_configure() {
local myeconfargs=(
- --disable-static
$(use_enable cpu_flags_x86_mmx mmx)
)
- ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+
+ econf "${myeconfargs[@]}"
}
-multilib_src_install_all() {
- einstalldocs
+src_install() {
+ default
+
find "${ED}" -type f -name '*.la' -delete || die
}