summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mutt/mutt-2.2.8.ebuild')
-rw-r--r--mail-client/mutt/mutt-2.2.8.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/mail-client/mutt/mutt-2.2.8.ebuild b/mail-client/mutt/mutt-2.2.8.ebuild
index 06bb916b3761..2f770033de52 100644
--- a/mail-client/mutt/mutt-2.2.8.ebuild
+++ b/mail-client/mutt/mutt-2.2.8.ebuild
@@ -99,16 +99,27 @@ src_prepare() {
main.c || die "Failed to add bug instructions"
fi
- local upatches=
# allow user patches
- eapply_user && upatches=" with user patches"
+ eapply_user
# patch version string for bug reports
local patchset=
use vanilla || patchset=", ${PATCHSET}"
- sed -i -e 's|"Mutt %s (%s)"|"Mutt %s (%s'"${patchset}${upatches}"')"|' \
+ sed -i -e 's|"Mutt %s (%s)"|"Mutt %s (%s'"${patchset}"')"|' \
muttlib.c || die "failed patching in Gentoo version"
+ # bug 864753: avoid warning about missing tools, currently the order
+ # is lynx, w3m, elinks, so remove lynx or w3m when not installed,
+ # elinks should be there via dep.
+ if use doc ; then
+ if ! has_version www-client/lynx ; then
+ sed -i -e '/lynx/d' doc/Makefile.am || die
+ fi
+ if ! has_version www-client/w3m ; then
+ sed -i -e '/w3m/d' doc/Makefile.am || die
+ fi
+ fi
+
# many patches touch the buildsystem, we always need this
AT_M4DIR="m4" eautoreconf