summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild')
-rw-r--r--llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild16
1 files changed, 1 insertions, 15 deletions
diff --git a/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild b/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild
index 731f7ca4c926..8fae33839019 100644
--- a/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild
+++ b/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build toolchain-funcs
+inherit multilib-build
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -28,17 +28,3 @@ RDEPEND="
)
)
"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}