summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild13
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch20
2 files changed, 28 insertions, 5 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
index f32c81a4c523..2885d6f78f0c 100644
--- a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
+++ b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop
+inherit autotools desktop
DESCRIPTION="Model-airplane flight simulation program"
HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
@@ -28,16 +28,19 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-overlink.patch
)
DOCS=( AUTHORS HISTORY )
-src_configure() {
- econf ac_cv_header_portaudio_h=$(usex portaudio)
+src_prepare() {
+ default
+
+ eautoreconf
}
-src_compile() {
- emake CGAL_LIBS=
+src_configure() {
+ econf ac_cv_header_portaudio_h=$(usex portaudio)
}
src_install() {
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch
new file mode 100644
index 000000000000..42bcc6e3d995
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch
@@ -0,0 +1,20 @@
+With CGAL now being header-only and boost-1.77.0 dropping thread-mt (not
+actually linking with it), these link attempts just cause unnecessary issues.
+
+https://bugs.gentoo.org/790779
+https://bugs.gentoo.org/808727
+--- a/configure.ac
++++ b/configure.ac
+@@ -227,5 +227,4 @@
+ has_CGAL="yes (found CGAL > v3)"
+ AC_CHECK_LIB(gmp,__gmpq_init,,AC_MSG_ERROR([gmp library not found. Please install it.]))
+- AC_CHECK_LIB(boost_thread-mt,main,,AC_MSG_ERROR([boost_thread-mt library not found. Please install it.]))
+ else
+ AC_DEFINE([CGAL_VERSION3], [1], [CGAL_VERSION3 compatibility])
+@@ -233,5 +232,5 @@
+ fi
+ CGAL_CFLAGS=-frounding-math
+- CGAL_LIBS=-lCGAL
++ CGAL_LIBS=
+ AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
+ else