summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/toppler/toppler-1.1.6-r2.ebuild')
-rw-r--r--games-puzzle/toppler/toppler-1.1.6-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.6-r2.ebuild b/games-puzzle/toppler/toppler-1.1.6-r2.ebuild
new file mode 100644
index 000000000000..08ec6d310bb3
--- /dev/null
+++ b/games-puzzle/toppler/toppler-1.1.6-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Reimplementation of Nebulous using SDL"
+HOMEPAGE="http://toppler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="acct-group/gamestat
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-mixer[vorbis]
+ sys-libs/zlib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fix-docdir.patch
+ "${FILESDIR}"/${P}-use-gamestat-group.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}