summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/openmw/files/openmw-0.48.0-Xt.patch17
-rw-r--r--games-engines/openmw/openmw-0.48.0.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/games-engines/openmw/files/openmw-0.48.0-Xt.patch b/games-engines/openmw/files/openmw-0.48.0-Xt.patch
new file mode 100644
index 000000000000..e24516af9155
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.48.0-Xt.patch
@@ -0,0 +1,17 @@
+https://gitlab.com/OpenMW/openmw/-/merge_requests/4407
+https://bugs.gentoo.org/925582
+
+--- a/apps/wizard/CMakeLists.txt
++++ b/apps/wizard/CMakeLists.txt
+@@ -98,11 +98,6 @@ if (BUILD_WITH_CODE_COVERAGE)
+ target_link_libraries(openmw-wizard gcov)
+ endif()
+
+-# Workaround for binutil => 2.23 problem when linking, should be fixed eventually upstream
+-if (CMAKE_SYSTEM_NAME MATCHES "Linux")
+-target_link_libraries(openmw-wizard dl Xt)
+-endif()
+-
+ if (WIN32)
+ INSTALL(TARGETS openmw-wizard RUNTIME DESTINATION ".")
+ endif(WIN32)
diff --git a/games-engines/openmw/openmw-0.48.0.ebuild b/games-engines/openmw/openmw-0.48.0.ebuild
index 65765800e7b5..0ca8e595f5d7 100644
--- a/games-engines/openmw/openmw-0.48.0.ebuild
+++ b/games-engines/openmw/openmw-0.48.0.ebuild
@@ -76,6 +76,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/openmw-0.48.0-gcc14.patch"
+ "${FILESDIR}/openmw-0.48.0-Xt.patch"
)
src_prepare() {