summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
index f1b0678fb4ea..fc82628bc521 100644
--- a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
+++ b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit desktop
+inherit desktop gnome2-utils
DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
HOMEPAGE="https://bitbucket.org/opentyrian/opentyrian/wiki/Home"
@@ -47,3 +47,11 @@ src_install() {
rm *.exe dpmi16bi.ovl loudness.awe || die "Failed to remove win32 binaries"
doins * || die "Failed to install game data"
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}