summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/Manifest1
-rw-r--r--games-arcade/spout/metadata.xml8
-rw-r--r--games-arcade/spout/spout-1.3.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
new file mode 100644
index 000000000000..be33c8a9ff39
--- /dev/null
+++ b/games-arcade/spout/Manifest
@@ -0,0 +1 @@
+DIST spout-unix-1.3.tar.bz2 92144 SHA256 9b113230c6b6e8cc8148139a65ceef5bb43d27cbe66cf2139c5b13d33251c7bc SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6 WHIRLPOOL 849758e71418c1dd3ea2a1450fea2b484f343c1a8d1f819fc181fe1fb7a0d571e785f61aa48734b53d817c8a1989740e1df82bfbdaa73fd590649c8753e6bea6
diff --git a/games-arcade/spout/metadata.xml b/games-arcade/spout/metadata.xml
new file mode 100644
index 000000000000..4f84a5e80d56
--- /dev/null
+++ b/games-arcade/spout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="freshmeat">spout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/spout/spout-1.3.ebuild b/games-arcade/spout/spout-1.3.ebuild
new file mode 100644
index 000000000000..051c3f4ed7b8
--- /dev/null
+++ b/games-arcade/spout/spout-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://freshmeat.net/projects/spout/"
+SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.6"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dogamesbin spout
+ doicon spout.png
+ make_desktop_entry spout "Spout"
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "To play in fullscreen mode, do 'spout f'."
+ elog "To play in a greater resolution, do 'spout x', where"
+ elog "x is an integer; the larger x is, the higher the resolution."
+ echo
+ elog "To play:"
+ elog "Accelerate - spacebar, enter, z, x"
+ elog "Pause - escape"
+ elog "Exit - shift+escape"
+ elog "Rotate - left or right"
+ echo
+}