summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.8.1.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild5
-rw-r--r--dev-vcs/git/git-9999.ebuild5
5 files changed, 15 insertions, 10 deletions
diff --git a/dev-vcs/git/git-2.8.1.ebuild b/dev-vcs/git/git-2.8.1.ebuild
index 2497aa5543f9..89aef012274b 100644
--- a/dev-vcs/git/git-2.8.1.ebuild
+++ b/dev-vcs/git/git-2.8.1.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 906428738da6..69b91dbc3a74 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 56b5b6bb100e..4de6ab76a7fe 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 2497aa5543f9..89aef012274b 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 5fbd63182f53..596de37ea700 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation