summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cpptest/cpptest-2.0.0.ebuild6
-rw-r--r--dev-util/cunit/cunit-2.1_p3.ebuild1
-rw-r--r--dev-util/gengetopt/gengetopt-2.23.ebuild6
-rw-r--r--dev-util/google-perftools/google-perftools-2.6.2.ebuild2
-rw-r--r--dev-util/google-perftools/google-perftools-2.7-r1.ebuild1
-rw-r--r--dev-util/google-perftools/google-perftools-2.7.ebuild1
-rw-r--r--dev-util/gperf/gperf-3.1.ebuild4
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.10.9.ebuild6
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.11.0.ebuild6
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.10.6.ebuild6
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.11.0.ebuild4
-rw-r--r--dev-util/systemtap/systemtap-3.1-r1.ebuild1
12 files changed, 9 insertions, 35 deletions
diff --git a/dev-util/cpptest/cpptest-2.0.0.ebuild b/dev-util/cpptest/cpptest-2.0.0.ebuild
index 8369dad2328c..3d5f2ce9f6ab 100644
--- a/dev-util/cpptest/cpptest-2.0.0.ebuild
+++ b/dev-util/cpptest/cpptest-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,9 +18,7 @@ RDEPEND="!dev-util/cpptest:0"
DOCS=( AUTHORS BUGS NEWS README )
src_configure() {
- econf \
- $(use_enable doc) \
- --htmldir=/usr/share/doc/${PF}/html/
+ econf $(use_enable doc)
}
src_install() {
diff --git a/dev-util/cunit/cunit-2.1_p3.ebuild b/dev-util/cunit/cunit-2.1_p3.ebuild
index ec60b09e6e41..9a51cda1919f 100644
--- a/dev-util/cunit/cunit-2.1_p3.ebuild
+++ b/dev-util/cunit/cunit-2.1_p3.ebuild
@@ -45,7 +45,6 @@ multilib_src_configure() {
append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
$(use_enable static-libs static) \
--disable-debug \
$(use_enable ncurses curses)
diff --git a/dev-util/gengetopt/gengetopt-2.23.ebuild b/dev-util/gengetopt/gengetopt-2.23.ebuild
index a11ba32f0ad2..0077d0818306 100644
--- a/dev-util/gengetopt/gengetopt-2.23.ebuild
+++ b/dev-util/gengetopt/gengetopt-2.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,7 +23,3 @@ src_prepare() {
eautoreconf
}
-
-src_configure() {
- econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
-}
diff --git a/dev-util/google-perftools/google-perftools-2.6.2.ebuild b/dev-util/google-perftools/google-perftools-2.6.2.ebuild
index 44f0d543dc3f..9d0679575689 100644
--- a/dev-util/google-perftools/google-perftools-2.6.2.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.6.2.ebuild
@@ -52,8 +52,6 @@ multilib_src_configure() {
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
econf \
- --htmldir=${EPREFIX}/usr/share/doc/${PF}/html \
- --docdir=${EPREFIX}/usr/share/doc/${PF} \
--enable-shared \
$(use_enable static-libs static) \
$(use_enable debug debugalloc) \
diff --git a/dev-util/google-perftools/google-perftools-2.7-r1.ebuild b/dev-util/google-perftools/google-perftools-2.7-r1.ebuild
index bafdc431a0d7..3e177a9c1d8d 100644
--- a/dev-util/google-perftools/google-perftools-2.7-r1.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.7-r1.ebuild
@@ -53,7 +53,6 @@ multilib_src_configure() {
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
econf \
- --docdir=${EPREFIX}/usr/share/doc/${PF} \
--enable-shared \
$(use_enable static-libs static) \
$(use_enable debug debugalloc) \
diff --git a/dev-util/google-perftools/google-perftools-2.7.ebuild b/dev-util/google-perftools/google-perftools-2.7.ebuild
index 8d7bcf2c2cc6..b120b338e577 100644
--- a/dev-util/google-perftools/google-perftools-2.7.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.7.ebuild
@@ -51,7 +51,6 @@ multilib_src_configure() {
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
econf \
- --docdir=${EPREFIX}/usr/share/doc/${PF} \
--enable-shared \
$(use_enable static-libs static) \
$(use_enable debug debugalloc) \
diff --git a/dev-util/gperf/gperf-3.1.ebuild b/dev-util/gperf/gperf-3.1.ebuild
index d1eb12188839..1a06518f0b75 100644
--- a/dev-util/gperf/gperf-3.1.ebuild
+++ b/dev-util/gperf/gperf-3.1.ebuild
@@ -21,7 +21,3 @@ src_prepare() {
eapply_user
}
-
-src_configure() {
- econf --htmldir='$(datarootdir)/doc/'"${PF}/html"
-}
diff --git a/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild b/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild
index 671fae563392..3797560c35e2 100644
--- a/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild
+++ b/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,7 +35,5 @@ pkg_pretend() {
}
src_configure() {
- econf \
- $(usex ust "" --without-lttng-ust) \
- --docdir=/usr/share/doc/${PF}
+ econf $(usex ust "" --without-lttng-ust)
}
diff --git a/dev-util/lttng-tools/lttng-tools-2.11.0.ebuild b/dev-util/lttng-tools/lttng-tools-2.11.0.ebuild
index 671fae563392..3797560c35e2 100644
--- a/dev-util/lttng-tools/lttng-tools-2.11.0.ebuild
+++ b/dev-util/lttng-tools/lttng-tools-2.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,7 +35,5 @@ pkg_pretend() {
}
src_configure() {
- econf \
- $(usex ust "" --without-lttng-ust) \
- --docdir=/usr/share/doc/${PF}
+ econf $(usex ust "" --without-lttng-ust)
}
diff --git a/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild b/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
index ead5c2518d16..d7181325dce3 100644
--- a/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
+++ b/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,3 @@ src_prepare() {
fi
eautoreconf
}
-
-src_configure() {
- econf --docdir=/usr/share/doc/${PF}
-}
diff --git a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
index a3aa0dbf6f7d..5c31aecfe564 100644
--- a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
+++ b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
@@ -36,7 +36,5 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable numa) \
- --docdir=/usr/share/doc/${PF}
+ econf $(use_enable numa)
}
diff --git a/dev-util/systemtap/systemtap-3.1-r1.ebuild b/dev-util/systemtap/systemtap-3.1-r1.ebuild
index 3f29609d2181..68d0985a32ec 100644
--- a/dev-util/systemtap/systemtap-3.1-r1.ebuild
+++ b/dev-util/systemtap/systemtap-3.1-r1.ebuild
@@ -71,7 +71,6 @@ src_prepare() {
src_configure() {
econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
--without-rpm \
--disable-server \
--disable-docs \