summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/shotgun/shotgun-0.9.1.ebuild')
-rw-r--r--dev-ruby/shotgun/shotgun-0.9.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/shotgun/shotgun-0.9.1.ebuild b/dev-ruby/shotgun/shotgun-0.9.1.ebuild
deleted file mode 100644
index c9c1d28826ff..000000000000
--- a/dev-ruby/shotgun/shotgun-0.9.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Forking implementation of rackup"
-HOMEPAGE="https://github.com/rtomayko/shotgun"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Warning: the code does not use gem versioning to make sure to load
-# only the right rack version so we might need to patch it to work :/
-ruby_add_rdepend 'dev-ruby/rack'
-ruby_add_bdepend "test? ( dev-ruby/bacon )"
-
-each_ruby_test() {
- ${RUBY} -Ilib test/test_shotgun_static.rb || die
- ${RUBY} -Ilib test/test_shotgun_loader.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- doman man/shotgun.1
-}