summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mocha/mocha-1.1.0.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-1.1.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/mocha/mocha-1.1.0.ebuild b/dev-ruby/mocha/mocha-1.1.0.ebuild
deleted file mode 100644
index b3a62d714f63..000000000000
--- a/dev-ruby/mocha/mocha-1.1.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
-HOMEPAGE="http://gofreerange.com/mocha/docs/"
-
-LICENSE="MIT"
-SLOT="1.0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sparc x86"
-IUSE=""
-
-ruby_add_bdepend "
- test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-
-ruby_add_rdepend "dev-ruby/introspection" # introspection ~> 0.0.1
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
-}
-
-each_ruby_test() {
- export MOCHA_NO_DOCS=true
- each_fakegem_test
-}