summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vpython/vpython-7.6.1.ebuild')
-rw-r--r--dev-python/vpython/vpython-7.6.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/vpython/vpython-7.6.1.ebuild b/dev-python/vpython/vpython-7.6.1.ebuild
new file mode 100644
index 000000000000..d2f5ea8d2a95
--- /dev/null
+++ b/dev-python/vpython/vpython-7.6.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="http://www.vpython.org/ https://pypi.org/project/vpython/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"