summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild')
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
new file mode 100644
index 000000000000..02e4c048c909
--- /dev/null
+++ b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
+HOMEPAGE="https://pypi.org/project/repoze.sphinx.autointerface/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-repoze[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install the namespace (it's the only subpackage)
+ python_moduleinto repoze.sphinx
+ python_domodule repoze/sphinx/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}