summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numba/numba-0.30.1.ebuild')
-rw-r--r--dev-python/numba/numba-0.30.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/numba/numba-0.30.1.ebuild b/dev-python/numba/numba-0.30.1.ebuild
deleted file mode 100644
index 6185c4a18300..000000000000
--- a/dev-python/numba/numba-0.30.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="http://numba.pydata.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/llvmlite-0.15[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( virtual/python-singledispatch[${PYTHON_USEDEP}] )
-"
-# doc building highly broken
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- ${PYTHON} -c "import numba; numba.test()" || die
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}