summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.4.7.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index 7e046c03807a..bf1fbee697af 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1 +1,2 @@
DIST markdown2-2.4.6.tar.gz 118321 BLAKE2B d6d053f9f19da0857664275280c9e12d59da9c88db5643df04c4538b3ac9e24feca66361dd05685b2a0d0281af353324e1b051bc315e78f2be9edb20367fa9be SHA512 4c8dbbfa828e6a01e05e714a5d79f8ec4137e80bbd221251d81fc9185f175dc9ac7ebd7b043d052a4b0c2963715d0d25429a22b2671f1512e92c48177c56e2ea
+DIST markdown2-2.4.7.tar.gz 118721 BLAKE2B 26cb03513a2665f40eb2c68e752aed3cfa78f6039d89da1a33a9de0996b37e2358c44f9e5078f5954a6b8ef3981aea2b06bc263fca16f1b0fad488c18387159b SHA512 e352578f57d6cdf3e59cb2ae10de218a8196cdbafe6257d76549758ead4997a33c65238664115232be4dbb3c63a81df4eb87c3a1248be8fb472d594e3fae087b
diff --git a/dev-python/markdown2/markdown2-2.4.7.ebuild b/dev-python/markdown2/markdown2-2.4.7.ebuild
new file mode 100644
index 000000000000..90f2a8132487
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.4.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+HOMEPAGE="
+ https://github.com/trentm/python-markdown2/
+ https://pypi.org/project/markdown2/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pygments-2.7.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}