summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonref')
-rw-r--r--dev-python/jsonref/jsonref-0.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/jsonref/jsonref-0.1.ebuild b/dev-python/jsonref/jsonref-0.1.ebuild
index 47c7cf272c50..b065699eaea7 100644
--- a/dev-python/jsonref/jsonref-0.1.ebuild
+++ b/dev-python/jsonref/jsonref-0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
inherit eutils distutils-r1
@@ -13,7 +13,10 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
-DEPEND=""
-RDEPEND="${DEPEND}"
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test tests.py || die
+}