summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json-rpc')
-rw-r--r--dev-python/json-rpc/json-rpc-1.10.1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
index dba072ebce48..7a21ad361ae1 100644
--- a/dev-python/json-rpc/json-rpc-1.10.1.ebuild
+++ b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1
@@ -16,13 +17,23 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
)"
+python_prepare_all() {
+ cat > jsonrpc/six.py <<- EOF
+ from __future__ import absolute_import
+ from six import *
+ EOF
+ distutils-r1_python_prepare_all
+}
+
python_test() {
esetup.py test
}