summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipaddr')
-rw-r--r--dev-python/ipaddr/ipaddr-2.2.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/ipaddr/ipaddr-2.2.0.ebuild b/dev-python/ipaddr/ipaddr-2.2.0.ebuild
index 2f58f9b96872..54a2b57f379c 100644
--- a/dev-python/ipaddr/ipaddr-2.2.0.ebuild
+++ b/dev-python/ipaddr/ipaddr-2.2.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
inherit distutils-r1
@@ -15,8 +16,6 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
python_prepare() {
if python_is_python3; then
2to3 -n -w --no-diffs *.py || die