summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis/hypothesis-3.6.0.ebuild')
-rw-r--r--dev-python/hypothesis/hypothesis-3.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-3.6.0.ebuild b/dev-python/hypothesis/hypothesis-3.6.0.ebuild
new file mode 100644
index 000000000000..30fce5cbc8cd
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis https://pypi.python.org/pypi/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ dev-python/uncompyle6[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+# optfeature "fake-factory support" dev-python/fake-factory
+}